Menu ▾ ▴

#5030 PAM authentication

1.850
open
nobody
None
5
2017-10-24
2017-10-14
No

webmin 1.850 on HP UX , browser Firefox ESR 52.4.0 (same happens when using IE 11)
root@cmctm18:8/69:/etc/opt/webmin$ uname -a
HP-UX cmctm18 B.11.31 U ia64 3691598475 unlimited-user license

PAM authentication works only if Support full PAM conversations is selected. Why?
It works OK with Webmin 1.540.
User does login but get the following error in the errorlog:
[date] [ip address] Document follows : This web server is running in SSL mo
de. Try the URL https://server:5032/ (server5032) instead.

Use of uninitialized value in numeric gt (>) at /opt/webmin/webmin/webmin-lib.pl line 1215.

1 Attachments

Discussion

  • Adrian Koszorus

    Adrian Koszorus - 2017-10-14

    The system is in trusted mode.
    When not using "support full PAM conversation" the errror
    Unknown pam_acct_mgmt return value : 30 "PAM_NOT_AUTHORIZED" is encountered.
    This is a help request rather than a bug.
    Didn't know how to post this elswhere ...

     
  • Jamie Cameron

    Jamie Cameron - 2017-10-14

    I'm not sure what could cause that, sorry ... I don't have an HP/UX system to test on.

     
    • Adrian Koszorus

      Adrian Koszorus - 2017-10-16

      Hello Jamie,
      concerning:"PAM authentication works only if Support full PAM conversations is selected. Why?
      It works OK with Webmin 1.540. (whitout support PAM full conversation == pam_conv=1 in miniserv.conf)
      User does login but get the following error in the errorlog:

      Use of uninitialized value in numeric gt (>) at /opt/webmin/webmin/webmin-lib.pl line 1215. "
      I do have a host available, but I can't give you acess to it. I could provide you needed informations if you tell me what to do, how to obtain them.
      Regards,Adrian

      On Saturday, October 14, 2017, 8:53:35 PM GMT+3, Jamie Cameron <jcameron@users.sf.net> wrote:
      

      I'm not sure what could cause that, sorry ... I don't have an HP/UX system to test on.

      [bugs:#5030] PAM authentication

      Status: open
      Group: 1.850
      Created: Sat Oct 14, 2017 06:18 AM UTC by Adrian Koszorus
      Last Updated: Sat Oct 14, 2017 07:12 AM UTC

      Owner: nobody
      Attachments:

      • miniserv.conf (1.1 kB; application/octet-stream)

      webmin 1.850 on HP UX , browser Firefox ESR 52.4.0 (same happens when using IE 11)
      root@cmctm18:8/69:/etc/opt/webmin$ uname -a
      HP-UX cmctm18 B.11.31 U ia64 3691598475 unlimited-user license

      PAM authentication works only if Support full PAM conversations is selected. Why?
      It works OK with Webmin 1.540.
      User does login but get the following error in the errorlog:
      [date] [ip address] Document follows : This web server is running in SSL mo
      de. Try the URL https://server:5032/ instead.

      Use of uninitialized value in numeric gt (>) at /opt/webmin/webmin/webmin-lib.pl line 1215.

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/webadmin/bugs/5030/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       
  • Jamie Cameron

    Jamie Cameron - 2017-10-16

    You can ignore that message about "Use of uninitialized value" .. it's a harmless perl warning.

    As for the original problem, are you saying that it worked OK in webmin 1.540 (which is pretty old), but not in the latest release?

     
    • Adrian Koszorus

      Adrian Koszorus - 2017-10-16

      Hello Jamie,
      thank you for your replies.Yes, it works OK - different, with Webmin 1.540 (whitout support PAM full conversation == pam_conv=1 in miniserv.conf) and on 1.850 it work only if support PAM full conversation is enabled. (otherwise in the miniserv.error log there is "Unknown pam_acct_mgmt return value : 30". Both versions of Webmin are on similar HP UX servers.

      We are using trusted mode.
      from /usr/include/security/pam_appl.h

      define PAM_NOT_AUTHORIZED     30      /* User is not authorized for

      terminal access */

      I think it is used on trusted mode only
      Regards,Adrian
      On Monday, October 16, 2017, 9:03:54 AM GMT+3, Jamie Cameron jcameron@users.sf.net wrote:

      You can ignore that message about "Use of uninitialized value" .. it's a harmless perl warning.

      As for the original problem, are you saying that it worked OK in webmin 1.540 (which is pretty old), but not in the latest release?

      [bugs:#5030] PAM authentication

      Status: open
      Group: 1.850
      Created: Sat Oct 14, 2017 06:18 AM UTC by Adrian Koszorus
      Last Updated: Sat Oct 14, 2017 05:53 PM UTC

      Owner: nobody
      Attachments:

      • miniserv.conf (1.1 kB; application/octet-stream)

      webmin 1.850 on HP UX , browser Firefox ESR 52.4.0 (same happens when using IE 11)
      root@cmctm18:8/69:/etc/opt/webmin$ uname -a
      HP-UX cmctm18 B.11.31 U ia64 3691598475 unlimited-user license

      PAM authentication works only if Support full PAM conversations is selected. Why?
      It works OK with Webmin 1.540.
      User does login but get the following error in the errorlog:
      [date] [ip address] Document follows : This web server is running in SSL mo
      de. Try the URL https://server:5032/ instead.

      Use of uninitialized value in numeric gt (>) at /opt/webmin/webmin/webmin-lib.pl line 1215.

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/webadmin/bugs/5030/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       
  • Jamie Cameron

    Jamie Cameron - 2017-10-17

    Is it possible to turn off trusted PAM mode for webmin, by editing the PAM config file? It's not clear what the response to a PAM_NOT_AUTHORIZED message should be otherwise.

     
  • Adrian Koszorus

    Adrian Koszorus - 2017-10-23

    Hello. No, we are forced to use PAM authentication.
    webmin 1.540 works OK with PAM authentication on the same trusted sysstem!
    I do need help for another issue: what are the parameters (miniserv.conf) that should be set to force the use of only TLSv1.2?

     
  • Jamie Cameron

    Jamie Cameron - 2017-10-24

    It's hard to say - version 1.540 was a long time ago, so many things may have changed in Webmin since then.

    Regarding the SSL ciphers, you can control these at Webmin -> Webmin Configuration -> SSL Encryption.

     

Log in to post a comment.