#4340 pkg update/reporting

1.660
closed-fixed
nobody
5
2014-01-04
2014-01-03
johann
No

sysinfo pg says 7 to update
update pg has 7 to update
click to update
yum runs through and successfully installs 7 updates
your completion notify says nothing was updated (end of yum processing pg)
go to the pkg update pg and it says nothing is available to update
go to the sysinfo pg and it says there are 6 (not 7) available to update
go back to the pkg update pg and it says nothing is available
go back the sysinfo pg and it says that everything is up-to-date
NOTE: refreshing the sysinfo pg will also cause the pg to correct itself

Related

Bugs: #4340

Discussion

  • Jamie Cameron

    Jamie Cameron - 2014-01-03

    Can you post the output from YUM that was displayed when updating packages in Webmin?

     
    • johann

      johann - 2014-01-04

      Building complete list of updates ..

      Now updating ca-certificates ..

      *Installing package(s) with command yum -y install ca-certificates ..*
      
      ================================================================================
        Package           Arch     Version                Repository              Size
      ================================================================================
      Updating:
        ca-certificates   noarch   2013.1.95-65.1.el6_5   PUIAS_6_core_Updates   1.1 M
      
      Transaction Summary
      ================================================================================
      Upgrade       1 Package(s)
      
      Total download size: 1.1 M
      
      Updated:
      
      *.. install complete.*
      

      Now updating ethtool ..

      *Installing package(s) with command yum -y install ethtool ..*
      
      ================================================================================
        Package      Arch        Version               Repository                 Size
      ================================================================================
      Updating:
        ethtool      x86_64      2:3.5-1.2.el6_5       PUIAS_6_core_Updates      100 k
      
      Transaction Summary
      ================================================================================
      Upgrade       1 Package(s)
      
      Total download size: 100 k
      
      Updated:
      
      *.. install complete.*
      

      Now updating iproute ..

      *Installing package(s) with command yum -y install iproute ..*
      
      ================================================================================
        Package        Arch          Version                   Repository         Size
      ================================================================================
      Updating:
        iproute        x86_64        2.6.32-31.el6.1           vz-updates        364 k
      
      Transaction Summary
      ================================================================================
      Upgrade       1 Package(s)
      
      Total download size: 364 k
      
      Updated:
      
      *.. install complete.*
      

      Now updating nss ..

      *Installing package(s) with command yum -y install nss ..*
      
      ================================================================================
        Package         Arch       Version              Repository                Size
      ================================================================================
      Updating:
        nss             x86_64     3.15.3-3.el6_5       PUIAS_6_core_Updates     822 k
      Updating for dependencies:
        nss-sysinit     x86_64     3.15.3-3.el6_5       PUIAS_6_core_Updates      40 k
        nss-tools       x86_64     3.15.3-3.el6_5       PUIAS_6_core_Updates     358 k
      
      Transaction Summary
      ================================================================================
      Upgrade       3 Package(s)
      
      Total download size: 1.2 M
      
      Updated:
      
      Dependency Updated:
      
      *.. install complete.*
      

      Now updating nss-sysinit ..

      *Installing package(s) with command yum -y install nss-sysinit ..*
      
      Package nss-sysinit-3.15.3-3.el6_5.x86_64 already installed and latest version
      
      *.. install complete.*
      

      Now updating nss-tools ..

      *Installing package(s) with command yum -y install nss-tools ..*
      
      Package nss-tools-3.15.3-3.el6_5.x86_64 already installed and latest version
      
      *.. install complete.*
      

      Now updating tzdata ..

      *Installing package(s) with command yum -y install tzdata ..*
      
      ================================================================================
        Package      Arch         Version             Repository                  Size
      ================================================================================
      Updating:
        tzdata       noarch       2013i-1.el6         PUIAS_6_core_Updates       447 k
      
      Transaction Summary
      ================================================================================
      Upgrade       1 Package(s)
      
      Total download size: 447 k
      
      Updated:
      
      *.. install complete.*
      

      No packages were installed. Check the messages above for the cause of the error.

      <- http://162.220.9.125:9874/package-updates/index.cgi?mode=updates&search=

      Thank you,

      Johann

      On 2014 Jan 03 14:04, Jamie Cameron wrote:

      Can you post the output from YUM that was displayed when updating packages in Webmin?


      [bugs:#4340] http://sourceforge.net/p/webadmin/bugs/4340/ pkg update/reporting

      Status: open
      Labels: Software Package Updates System Information yum processing
      Created: Fri Jan 03, 2014 09:26 PM UTC by johann
      Last Updated: Fri Jan 03, 2014 09:26 PM UTC
      Owner: nobody

      sysinfo pg says 7 to update
      update pg has 7 to update
      click to update
      yum runs through and successfully installs 7 updates
      your completion notify says nothing was updated (end of yum processing pg)
      go to the pkg update pg and it says nothing is available to update
      go to the sysinfo pg and it says there are 6 (not 7) available to update
      go back to the pkg update pg and it says nothing is available
      go back the sysinfo pg and it says that everything is up-to-date
      NOTE: refreshing the sysinfo pg will also cause the pg to correct itself


      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/webadmin/bugs/4340/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #4340

  • Jamie Cameron

    Jamie Cameron - 2014-01-04

    Thanks .. it looks like the YUM output format is a little different to what Webmin expects. Which Linux distribution and version are you running there?

     
    • johann

      johann - 2014-01-04

      yum.noarch 3.2.29-43.el6_5
      Linux s5.4ssl.us 2.6.32-042stab084.12 #1 SMP Tue Nov 26 20:18:08 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux

      Thank you,

      Johann

      On 2014 Jan 03 23:25, Jamie Cameron wrote:

      Thanks .. it looks like the YUM output format is a little different to what Webmin expects. Which Linux
      distribution and version are you running there?


      [bugs:#4340] http://sourceforge.net/p/webadmin/bugs/4340/ pkg update/reporting

      Status: open
      Labels: Software Package Updates System Information yum processing
      Created: Fri Jan 03, 2014 09:26 PM UTC by johann
      Last Updated: Fri Jan 03, 2014 10:04 PM UTC
      Owner: nobody

      sysinfo pg says 7 to update
      update pg has 7 to update
      click to update
      yum runs through and successfully installs 7 updates
      your completion notify says nothing was updated (end of yum processing pg)
      go to the pkg update pg and it says nothing is available to update
      go to the sysinfo pg and it says there are 6 (not 7) available to update
      go back to the pkg update pg and it says nothing is available
      go back the sysinfo pg and it says that everything is up-to-date
      NOTE: refreshing the sysinfo pg will also cause the pg to correct itself


      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/webadmin/bugs/4340/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #4340

  • Jamie Cameron

    Jamie Cameron - 2014-01-04

    OK, I see the cause of the problem now - the YUM output format is different on your system to what Webmin expects, causing it to not detect package installs. This will be fixed in the next release.

     
    • johann

      johann - 2014-01-04

      what re the disparity between the sysinfo page and the pkg update page? i have seen this before there was any
      yum I/O problem.

      Thank you,

      Johann

      On 2014 Jan 04 11:01, Jamie Cameron wrote:

      OK, I see the cause of the problem now - the YUM output format is different on your system to what Webmin
      expects, causing it to not detect package installs. This will be fixed in the next release.


      [bugs:#4340] http://sourceforge.net/p/webadmin/bugs/4340/ pkg update/reporting

      Status: closed-fixed
      Labels: Software Package Updates System Information yum processing
      Created: Fri Jan 03, 2014 09:26 PM UTC by johann
      Last Updated: Sat Jan 04, 2014 07:25 AM UTC
      Owner: nobody

      sysinfo pg says 7 to update
      update pg has 7 to update
      click to update
      yum runs through and successfully installs 7 updates
      your completion notify says nothing was updated (end of yum processing pg)
      go to the pkg update pg and it says nothing is available to update
      go to the sysinfo pg and it says there are 6 (not 7) available to update
      go back to the pkg update pg and it says nothing is available
      go back the sysinfo pg and it says that everything is up-to-date
      NOTE: refreshing the sysinfo pg will also cause the pg to correct itself


      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/webadmin/bugs/4340/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #4340

      • Jamie Cameron

        Jamie Cameron - 2014-01-04

        They have the same cause - the sysinfo page gets out of sync because Webmin
        thinks it hasn't installed packages when it really has.

        On 04/Jan/2014 11:37 johann vonpreussen@users.sf.net wrote ..

        what re the disparity between the sysinfo page and the pkg update page? i
        have seen this before there was any
        yum I/O problem.

        Thank you,

        Johann

        On 2014 Jan 04 11:01, Jamie Cameron wrote:

         OK,  I  see the cause of the problem now - the YUM output format is
         different on your system to what Webmin
         expects, causing it to not detect package installs. This will be fixed in
         the next release.
           ______________________________________________________________
        
         [1][bugs:#4340] [2]http://sourceforge.net/p/webadmin/bugs/4340/ pkg
         update/reporting
        
         Status: closed-fixed
         Labels: Software Package Updates System Information yum processing
         Created: Fri Jan 03, 2014 09:26 PM UTC by johann
         Last Updated: Sat Jan 04, 2014 07:25 AM UTC
         Owner: nobody
        
         sysinfo pg says 7 to update
         update pg has 7 to update
         click to update
         yum runs through and successfully installs 7 updates
         your completion notify says nothing was updated (end of yum processing pg)
         go to the pkg update pg and it says nothing is available to update
         go to the sysinfo pg and it says there are 6 (not 7) available to update
         go back to the pkg update pg and it says nothing is available
         go back the sysinfo pg and it says that everything is up-to-date
         NOTE: refreshing the sysinfo pg will also cause the pg to correct itself
           ______________________________________________________________
        
         Sent   from  sourceforge.net  because  you  indicated  interest  in
         [3]https://sourceforge.net/p/webadmin/bugs/4340/
        
         To    unsubscribe    from    further    messages,    please   visit
         [4]https://sourceforge.net/auth/subscriptions/
         _________________________________________________________________
        

        [5][bugs:#4340] pkg update/reporting

        Status: closed-fixed
        Labels: Software Package Updates System Information yum processing
        Created: Fri Jan 03, 2014 09:26 PM UTC by johann
        Last Updated: Sat Jan 04, 2014 07:00 PM UTC
        Owner: nobody

        sysinfo pg says 7 to update
        update pg has 7 to update
        click to update
        yum runs through and successfully installs 7 updates
        your completion notify says nothing was updated (end of yum processing pg)
        go to the pkg update pg and it says nothing is available to update
        go to the sysinfo pg and it says there are 6 (not 7) available to update
        go back to the pkg update pg and it says nothing is available
        go back the sysinfo pg and it says that everything is up-to-date
        NOTE: refreshing the sysinfo pg will also cause the pg to correct itself
        ___________

        Sent from sourceforge.net because you indicated interest in
        [6]https://sourceforge.net/p/webadmin/bugs/4340/

        To unsubscribe from further messages, please visit
        [7]https://sourceforge.net/auth/subscriptions/

         

        Related

        Bugs: #4340

  • Jamie Cameron

    Jamie Cameron - 2014-01-04
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks