#1334 Virtualmin 1.5 does'nt install on Gentoo

1.110
closed
None
5
2003-10-20
2003-10-19
No

I got this when trying to install :

Failed to install module from
/tmp/virtual-server-1.5.wbm.gz : Module sendmail does
not support this operating system (Gentoo Linux Any
version)

Adding a space after gentoo-linux on
sendmail/module.info fixed it.

os_support=solaris slackware-linux redhat-linux
mandrake-linux suse-linux united-linux debian-linux
freebsd hpux irix macos open-linux openserver unixware
turbo-linux openbsd corel-linux cobalt-linux aix netbsd
msc-linux osf1 generic-linux gentoo-linux {-r
"/etc/sendmail.cf" || -r "/etc/mail/sendmail.cf"}

daniel

ps: No virtualmin category!?, hope I'm posting on the
right place.

Discussion

  • Jamie Cameron

    Jamie Cameron - 2003-10-20
    • assigned_to: nobody --> jcameron
    • status: open --> closed
     
  • Jamie Cameron

    Jamie Cameron - 2003-10-20

    Logged In: YES
    user_id=129364

    This happens because virtualmin 1.5 is packaged with a Sendmail module
    update, which only installs on Gentoo if sendmail.cf exists. The hack
    work-around is to run touch /etc/sendmail.cf before installing.
    Future virtualmin versions won't have this bug ..

     
  • Daniel Feliciano Branco

    Logged In: YES
    user_id=83906

    Still failed with virtual-server-1.62, but the touch
    /etc/sendmail.cf worked fine. Thanks

    daniel

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks