#9 tp_smapi 0.21 doesn't work on A21m

open
nobody
None
5
2006-08-01
2006-06-25
Dan Smolik
No

I have Thinkpad A21M and compile smapi 0.21 when I try
cat some sysfs files I get nothing and in dmesg found
this. I use 2.6.17.
Thanks
Dan

tp_base: tp_base 0.21 loaded.
tp_smapi: tp_smapi 0.21 loading...
tp_smapi: successfully loaded (smapi_port=0xb2).
ibm_acpi: IBM ThinkPad ACPI Extras v0.12a
ibm_acpi: http://ibm-acpi.sf.net/
ibm_acpi: dock device not present
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row
thinkpad controller read(0x01,0x00): failed requesting row

Discussion

  • Thomas Hood

    Thomas Hood - 2006-08-01
    • summary: A21m doesn't work with smapi --> tp_smapi 0.21 doesn't work on A21m
     
  • Bryan Hundven

    Bryan Hundven - 2008-09-28

    It would help the developers if you sent the output of the command:

    sudo dmidecode -s system-version

    This way they can update the hdaps_whitelist[] structure to include your platform.

    -Bryan

     

Log in to post a comment.