Stellarium no longer works after update to Windows 8.1

Feedback
Anonymous
2013-11-16
2015-10-01
  • Anonymous - 2013-11-16

    HP Elitebook 8530p with Windows 8.1, Ati Mobility Radeon HD 3650

    Stellarium worked fine under Windows 8, but under 8.1 the following error is diplayed upon running the program: "Your platform does not support minimal required OpenGL 1.2. Please upgrade drivers for graphics card."

    The drivers have been updated to the latest version from amd.com.

    I presume it really is a drivers thing. After updating them, the Device Manager still says "ATI Mobility Radeon HD 3650 (Microsoft Corporation - WDDM v1.1)" under Display adapters, and the ATI Catalyst Control Panel won't start because "There are currently no settings that can be configured using Catalyst Pro Control Center." Looks like I am stuck with some bad Microsoft drivers.

    Bummer.

     
  • Anonymous - 2013-11-16

    Found the solution here: http://blog.rthand.com/post/2012/11/01/Getting-proper-OpenGL-driver-for-older-AMD(ex-ATI)-graphics-cards-on-Windows-8.aspx

     
    • Anonymous - 2014-06-11

      This link is broken

       
  • Anonymous - 2013-11-29

    Mine is a ACER Aspire V5-752G with Windows8.1 and NVIDIA GEFORCE 750M

    The problem is, when I try to open Stellarium, I see a displayed error: the program cann´t work more. I´ve already upgraded the driver of the described graphic card, tried with the compatibility mode for Win 7 too, but nothing of these procedures seems to help.

    What can I do?? I miss my home planetarium! :´(

     
  • Anonymous - 2014-05-13

    "Your platform does not support minimal required OpenGL 1.2"
    I'm running 8.1 on an AMD Quad Core with a PowerColor video card.
    Why can't we get an updated OpenGL?

     
    • Alexander Wolf

      Alexander Wolf - 2014-06-08

      You need update drivers for graphics card.

       
      • Comment has been marked as spam. 
        Undo

        You can see all pending comments posted by this user  here

        Anonymous - 2015-10-01

        Mine is upgrade to Windows 10 from Windows 7, same error message... WHERE are these magical update drivers supposed to be found? Could you provide information as to what website and URL to get them from and what drivers they are? All my stuff says "latest driver installed" so not sure what exactly I'm supposed to be updating! All I know is Stellarium won't work on this Acer Aspire desktop since the upgrade.

         
  • surferofskies

    surferofskies - 2014-06-08

    Strange, for me it runs perfectly under Win 8.1 even when running in a VMware session under OSX.

     
  • barrykgerdes

    barrykgerdes - 2014-06-12

    Yes that is normal Vmware has its own built in driver for the screen. If I run XP on this computer there is no screen driver so Stellarium runs terrible but if I run XP in a VMware session stellarium installed there runs great.

    Barry

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks