Bugs item #1496014, was opened at 2006-05-27 16:42
Message generated for change (Comment added) made by nitwit
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=540672&aid=1496014&group_id=74338
Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: MySQL
Group: SQLObject release (specify)
Status: Open
Resolution: None
Priority: 5
Submitted By: Neil Muller (nitwit)
Assigned to: Nobody/Anonymous (nobody)
Summary: None in enumValues fails
Initial Comment:
SQLObject-0.7.1b1
MySQL does not allow NULL inside the ENUM statemnt, so
the construction
EnumCol(enumValues=['a','b',None],default=None) will fail.
Since this construction works fine with sqlite and
postgresql, this is an issue. The attached patch fixes
the problem here.
----------------------------------------------------------------------
>Comment By: Neil Muller (nitwit)
Date: 2006-05-29 22:39
Message:
Logged In: YES
user_id=698097
I was pointed at
http://archives.postgresql.org/pgsql-sql/2004-12/msg00065.php,
which illustrates that NULL in the check constraint approach
used to implement EnumCol for postges and other databases
behave in an unexpected way due to the three state logic SQL
uses. Thus a believe this second patch, which excludes Nones
from all the database backends should be prefferred.
----------------------------------------------------------------------
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=540672&aid=1496014&group_id=74338
|