The sodipodi depends on an or more DLLs.

  • w-jonas

    w-jonas - 2005-10-25

    The sodipodi depends on an or more DLLs, that are not easy to find and to install in the windows.

    Reason is not offered a compacted file '. ZIP ' with everything inside?

    • w-jonas

      w-jonas - 2005-10-25

      Could anybody offer a link, for download of the last version of that program together with all the quarrels included in a compacted file '.zip' ?

    • Philippe Verdy

      Philippe Verdy - 2005-11-24

      Sidipodi 0.34for WinXP depends on "zlib-1.dll" but it installs "zlib.dll"; renaming the dllseems to solve that issue, but then it claims that the installed "libgmodule-2.0-0.dll" does not include the entry point "g_module_open_utf8".
      How to solve this DLL nightmare?

      Which DLLs are needed for Sodipodi? Why doesn't it come with at least its own versions of these?

      Note: I already have GTK+ and GLIB runtime installed and present in my path:

      PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Java\jdk1.5.0_05\bin;C:\Program Files\Fichiers communs\GTK\2.0\bin

      The latest GTK+ installation contains a smaller version of "zlib1.dll" (the latest one): should I remove the old gmodule dlls installed with sodiprodi?

      I found a temporary (not clean) solution by doing thisafter install:

      * make sure that GTK+ 2.0 is installed and in PATH
      * copy zlib1.dll from GTK\2.0\bin into c:\Program Files\Sodiprodi\ TWICE under names zlib.dll and zlib-1.dll
      * remove the installed libgmodule-2.0-0.dll from Sodipodi (it will use the up-to-date version found in \Program Files\Common Files\GTK+\2.0\bin)
      * remove the installed freetype6.dll from Sodipodi (it will use the up-to-date version found in \Program Files\Common Files\GTK+\2.0\bin)

      Hope this helps others during the interim

    • MalkaDelilah

      MalkaDelilah - 2006-01-14

      OMG!  What a huge ordeal for end users like me.  I ran into the same problem and tried simply renaming the file too... with the same results you had.  I'm sure this proceedure is easier than it looks...  but first glance tells me most would just give up and try some other program at this point...  Me?  naw..  I am still going to try.  I like new beta programs & yours looks interesting - hard to get installed, but interesting.  Next day off work I will try to follow these instructions...  though some of the steps are a bit unclear for my level of expertise...  I will try...

      If you have a more user friendly work around - Please feel free to post it for me... :-)


    • Chris Pelling

      Chris Pelling - 2006-01-31

      This is quite annoying, and it's remained unfixed for three months; which is a shame, because Sodipodi is a great tool and I know it used to work! Someone please fix the download package. :-)

      I found that the following, simplified solution works for me (under Windows 2000/XP):

      1. Download and install the binary package of Sodipodi.
      2. Browse to the installation directory.
      3. Make a copy of zlib.dll called zlib-1.dll. (That's a COPY, not a rename - you need both DLLs.)
      4. Rename libgmodule-2.0-0.dll to libgmodule-2.0-0.bak
      5. Download this file:
      6. Inside that ZIP archive is another version of libgmodule-2.0-0.dll, in the "bin" directory. Extract it to your Sodipodi directory.
      7. Run Sodipodi to make sure it works.

      I didn't find that I needed to get a new version of the Freetype DLL; the included one seems to work fine. Your mileage may vary.

    • Peter van Summeren

      just downloaded sodipodi. It can't find zlib-1.dll. What about repair? Just a good download?
      with friendly greetings,

    • A. BinTalal

      A. BinTalal - 2006-11-16

      When I started Sodipodi for the first time he refused to start because he couldn't find zlib-1.dll, I searched my computer for it and only found zlib.dll and zlib1.dll (the latter from gimp 2.0, 69kb instead of 80kb). I copied zlib1.dll to Sodipodi directory and renamed it zlib-1.dll, now it satarted.

      So I started a new document put some shapes on it and saved, everything ok, then I tried exporting to png and it crashed.

      I deleted zlib-1.dll and renamed zlib.dll as zlib-1.dll, now it won't start because it couldn't find zlib.dll

      So I copied the file and renamed the copy zlib.dll, so I had two copies of the same file (the one installed by the program) one named zlib.dll and the other zlib-1.dll. It worked and exported to png perfectly.

    • multiplex777

      multiplex777 - 2009-04-17

      I have followed the steps suggested here, but I get the alert:
      The procedure entry point xmlCtextGetLastError could not be found located in the dynamic link library libxml2.dll.

      Any ideas?

      Thank you.


Log in to post a comment.