SourceForge has been redesigned. Learn more.
Close

#1 including SOAP::MIME but not using attachments breaks

open
nobody
None
5
2003-02-12
2003-02-12
Anonymous
No

-----Original Message-----
From: ninethirty <ninethirty@yahoo.com>
[mailto:ninethirty@yahoo.com]
Sent: Tuesday, February 11, 2003 2:33 PM
To: soaplite@yahoogroups.com
Subject: [soaplite] Problems with SOAP::MIME (or with
me)

I am writing a Perl SOAP client that needs to be able to
handle attachments, so I have included SOAP::MIME
and MIME::Entity, as described in message 1977 from
Paul. But in the same script, before I get to the point
where I make a call that uses the attachments, I try
to make a normal SOAP call without attachments. This
call fails with no error. Everything just stops. Does
including SOAP::MIME break the non-attachment-
sending functionality?

I've tried sending it a blank array into the $soap->parts(
@blank_array_here ) and similar tricks, but no luck.

I can split this script into two scripts, if necessary, I just
need to know if it is really necessary or if I am doing
something wrong.

Thanks!

Matt

Discussion

  • Matt Hoffman

    Matt Hoffman - 2003-03-07

    Logged In: YES
    user_id=728929

    I've done a bit more looking at this, and found that the
    non-attachment message IS going across the wire. However,
    the script hangs apparently while it is processing the
    response. I'll continue looking into it.

    Matt

     
  • Nobody/Anonymous

    Logged In: NO

    who can help me about SOAP::Lite attachments
    I want to send file to server , i need setup what they
    i thanks

    send my mail : theanhnv20@yahoo.com

     

Log in to post a comment.