#127 no subtitles

closed-works-for-me
nobody
linux (114)
5
2008-04-20
2008-04-15
Anonymous
No

smaplayer doesn't display subtitles opening a movie .mkv with srt subtitles...

Discussion

  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    I've just tested right now to open a mkv file, then load a srt subtitle and it works.

    What version of mplayer do you have installed?

     
  • Ricardo Villalba

    • status: open --> pending
     
  • Ricardo Villalba

    • status: pending --> pending-works-for-me
     
  • Nobody/Anonymous

    • status: pending-works-for-me --> open-works-for-me
     
  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    I can see the srt subtitles even if the SSA/ASS library is disabled.

    Maybe you need to select an appropriate font in preferences?

     
  • Ricardo Villalba

    • status: open-works-for-me --> pending-works-for-me
     
  • Nobody/Anonymous

    Logged In: NO

    I'm using the default font setting on smplayer.

     
  • Nobody/Anonymous

    • status: pending-works-for-me --> open-works-for-me
     
  • Nobody/Anonymous

    Logged In: NO

    I'm using the default font setting on smplayer.

     
  • Nobody/Anonymous

    Logged In: NO

    I'm using the default font setting on smplayer.

     
  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    Silly question: do you choose the srt subtitle in Subtitles->Select?

    Does srt subtitles work in other videos?

     
  • Ricardo Villalba

    • status: open-works-for-me --> pending-works-for-me
     
  • Anonymous - 2008-04-17

    Logged In: YES
    user_id=2065119
    Originator: NO

    i am using subtitle in Subtitles->Select, but i just notice that this happens also with mkv files with SSA/ASS subtitles... they only appear when i enable the use SSA/ASS library.. this is really bugging me... if u got aim/msn let me know so i can chat there with you...

     
  • Anonymous - 2008-04-17
    • status: pending-works-for-me --> open-works-for-me
     
  • Ricardo Villalba

     
    Attachments
  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    I attached a screenshot of smplayer, playing a mkv file and using an external srt file. The SSA/ASS lib is disabled.

    I'm using smplayer svn r1148, mplayer svn r26446. The subtitle font selected in preferences is the system font "Arial".

    As you can see it works. So I think this is not a bug in smplayer.

    Please check your configuration, specially the subtitle font.

    File Added: mkv_srt_subs.jpg

     
  • Ricardo Villalba

    • status: open-works-for-me --> closed-works-for-me
     
  • Anonymous - 2008-04-19
    • status: closed-works-for-me --> open-works-for-me
     
  • Anonymous - 2008-04-19

    Logged In: YES
    user_id=2065119
    Originator: NO

    Something weird its going on here, i just formated and install Ubuntu hard RC version, and i cannot install mplayer latest one (mplayer_1.0rc2svn25873_i386.deb) and i get an error message installing with gdebi-gtk 0.3.7. The error says "Error: Dependency is not satisfiable: libconfhelper-perl".. so i install using apt-get install from terminal, and now i am using Version: 0.6.0rc4 (SVN r1120)
    Compiled with Qt 4.2.3

    Using MPlayer SVN r24722

    ... Now the weird thing is that i can see the subtitles now without enabling the use SSA/ASS library. Maybe it has something to do with MPlayer rather than smplayer....

     
  • Anonymous - 2008-04-19

    Logged In: YES
    user_id=2065119
    Originator: NO

    Something weird its going on here, i just formated and install Ubuntu hard RC version, and i cannot install mplayer latest one (mplayer_1.0rc2svn25873_i386.deb) and i get an error message installing with gdebi-gtk 0.3.7. The error says "Error: Dependency is not satisfiable: libconfhelper-perl".. so i install using apt-get install from terminal, and now i am using Version: 0.6.0rc4 (SVN r1120)
    Compiled with Qt 4.2.3

    Using MPlayer SVN r24722

    ... Now the weird thing is that i can see the subtitles now without enabling the use SSA/ASS library. Maybe it has something to do with MPlayer rather than smplayer....

     
  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    Glad finally it works for you.

    (Maybe the problem was that the other mplayer build didn't have a default font)

     
  • Ricardo Villalba

    • status: open-works-for-me --> closed-works-for-me
     
  • Anonymous - 2008-04-20

    Logged In: YES
    user_id=2065119
    Originator: NO

    maybe that was the problem.. anyway thanks for your help...

     
  • Anonymous - 2008-04-20
    • status: closed-works-for-me --> open-works-for-me
     
  • Ricardo Villalba

    • status: open-works-for-me --> closed-works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks