7-Zip 9.34 alpha

2014-06-22
2016-03-23
<< < 1 2 3 4 5 6 > >> (Page 3 of 6)
  • Ricardo

    Ricardo - 2014-06-30

    Below download links you can clearly read:
    "7-Zip 9.34 alpha version is provided without source code.
    Source code will be released in future beta version."

     
  • Łukasz

    Łukasz - 2014-07-02

    I have Windows 8.1 64 bit. cannot associate files or add to the context menu of the menu of 7-zip, because I show up 2 messages. Please improve. This happens in both versions of 7-zip 32 and 64 bit.

    I had to change it to an easy 7-zip, and I want to use 7-zip

     
    • n00b

      n00b - 2014-07-04

      Did you try to run 7z manager as administrator (right click) and then set associations? Context menu will work only with the same OS version - in your case is 7z x64. Please write here these messages.

       
  • Łukasz

    Łukasz - 2014-07-04

    You cannot uncheck those associations which said, after you press ok, the error message access denied.

    http://images61.fotosik.pl/1139/cb3d0f9356ec0fd3med.jpg

    edit:

    even in catalogs, system do not want to pack your directories, folders and files through the context menu, add to ....7z and add to ... zip

     
    Last edit: Łukasz 2014-07-05
    • n00b

      n00b - 2014-07-05

      Maybe you have AV software that sandbox 7zip?
      Try disable it. (What kind of AV do you have?)
      Try to disable User Account Control - set it to minimum.
      If these tips failed, then email to me - n00b@wp.pl

       
    • Ricardo

      Ricardo - 2014-07-07

      You need to execute 7zFM with administrative rights before setting associations. You should not disable UAC.

       
  • Łukasz

    Łukasz - 2014-07-05

    ok, it works. I have avast free

     
  • academic

    academic - 2014-07-08

    -ssw switch doesn't work in command line version :-(

     
  • Igor Pavlov

    Igor Pavlov - 2014-07-08

    Yes, it will be fixed in next version.

     
  • john lee

    john lee - 2014-07-10

    Igor, can you please clarify the status of -spf (in previous version) in the help file and in the code (see separate thread discussion 'save full path name') Think I've used it & it has worked ok. It is not in help for the latest 9.34.

     
  • jacky yang

    jacky yang - 2014-07-13

    First the CRC SHA is useful.
    You should save the result of CRC SHA in a text file.
    So someone can change the case of character in CRC SHA.

     
  • jacky yang

    jacky yang - 2014-07-13

    Can you provide the feature in the future version.
    ( From WinRAR Help )
    Put each file to separate archive
    Put each selected file or folder to separate archive. If you set this option, an entered archive name is treated only as a destination path for new archives (if it is not a folder, its name part is ignored) and archive names are generated basing on file names.

     
  • jacky yang

    jacky yang - 2014-07-13

    You can add a Edit Box or Combo Box with a select path Button in Add to Archive Dialog.
    So someone can select a save path quickly more than use File Save As dialog box.

     
  • john lee

    john lee - 2014-07-13

    Next version (eg the beta) is for fixes - not new functionality. j

     
  • jacky yang

    jacky yang - 2014-07-13

    I am so happy! But Add MD5 in CRC SHA is so far.

     
    Last edit: jacky yang 2014-07-13
  • john lee

    john lee - 2014-07-14

    re -spf (see above), I have just tried it on this version and the switch is accepted by 7z but then doing a 7z l (list) doesn't show full path names and -spf is not in help, so clarification needed. Believe it worked in a previous alpha/beta! j

     
    Last edit: john lee 2014-07-14
  • Andy Fielding

    Andy Fielding - 2014-07-14

    Thanks for this! I thought I'd have to switch to a different archiver, because the previous 7-Zip (beta) didn't show context-menu commands in my file manager (xplorer2). v9.35 alpha fixes that, though—so whether it was intentional or not, nice work! I've been using it for a week and haven't had any problems.

    Cheers, Ander

     
  • Valentyn Shtronda

    I often use password in archives but there is no hotkey for "Enter password" field in "Add to Archive" dialog. Some other fields are missing hotkeys too.

    Considering that password is probably used more often than additional parameters, I would suggest to use:
    - R for "Parameters"
    - P for "Enter password"
    - O for "Show password"
    - H for "Path mode"
    - C for "Compress shared files"
    - I for "Delete files after compression"
    - Dot for "...".

    Also I noted that N is used twice:
    - for "Number of CPU threads"
    - and for "Encrypt file names".
    You may fix this by using Y for "Encrypt file names" or T for "Number of CPU threads".

    Thanks!

     
    Last edit: Valentyn Shtronda 2014-07-16
  • ante

    ante - 2014-07-20

    I've been having this issue since 9.20. I thought trying the alpha of the newest version would solve it, but it hasn't. I have files, whether they be .zip or .7z, that are zipped with multiple subfolders, or sometimes just a single subfolder. Whenever I use 7zip to unzip them, the program decides to remove all files from within the subfolders and place them in the main folder, leaving all subfolders empty. This isn't usually a problem. However, I have a program I am trying to unzip that is in .7z format, and in order for it to run appropriated, files must be in their designated folders. I have no clue what goes where since 7zip took everything out of their original subfolders. Is there some setting I'm missing here that stops the program from doing this? Way back when, it didn't do this. If it's just something I'm being blind to, can you kindly explain the process? Thank you much!

    **I should add that it doesn't do this if I manually extract everything by opening the actual program and locating my file. However, it does this EVERY TIME I right click and extract by that method, instead of opening the program. Is there a reason it does this?

     
    Last edit: ante 2014-07-20
    • gora2

      gora2 - 2014-07-20

      ante
      Сontext menu -> 7-Zip -> Extract file... -> Path mode: "No pathnames"
      change to: "Full pathnames"

       
  • Starshadow

    Starshadow - 2014-07-22

    I found a bug in extracting files from very large .iso files e.g. a Blu-ray image. I am trying to extract a file that exists at offset 0x2B0F40000 in the .iso file (I found it by opening the .iso in a hex editor). When I extract this file with 7-zip 9.31 and newer, the extracted file contains a chunk of data from some other file which exists at offset 0xB0F40000 (missing the leading 2) in the .iso file. 9.30 and earlier is able to extract the file correctly.

     
    • Igor Pavlov

      Igor Pavlov - 2014-07-22

      Yes, there is such bug in 9.31-9.34.
      I'll fix it in next version.
      Thanks for report!!!

       
  • netlord

    netlord - 2014-07-28

    Hi there

    i want to use 7zip as a installer with pe
    therefore i created an config.txt with this content

    ;!@Install@!UTF-8!
    Path=".\"
    Progress="No"
    ExecuteFile="cmd"
    ExecuteParameters="/c install.cmd"
    ;!@InstallEnd@!

    It doesnt work with this version.... (with the older version its working - but not unter PE64)
    It seems that the config.txt is completly ignored.

     
    • Igor Pavlov

      Igor Pavlov - 2014-07-28

      7-Zip doesn't support the following script command:
      Path=".\"

       
  • gora2

    gora2 - 2014-07-30

    Hi, Igor
    File vcredist_x86.exe (http://www.microsoft.com/ru-ru/download/details.aspx?id=30679) is cab SFX
    7-zip by default opens it incorrectly
    7-zip mode "cab" opens it incorrectly
    7-zip mode "#" or "#:e" opens it correctly

     
<< < 1 2 3 4 5 6 > >> (Page 3 of 6)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks