SourceForge has been redesigned. Learn more.
Close

#3499 COMI: Speech drops out, causing crash/freeze

Monkey Island 3
closed-fixed
Max Horn
7
2008-01-07
2007-12-11
Tim
No

In the Windows English version of COMI, shortly after Rottingham boards at the beginning of Act III, the speech drops out (immediately after Rottingham says "You know, of course, that in a swordfight, a sharp wit is much more important than a sharp blade."). When speech first drops out, I see

(52:125:0xE99): BundleMgr::decompressSampleByName() Failed finding voice 2302-R~1.IMX
(52:125:0xE9F): Opening hashed: /home/tburke/shared/SCUMM/Games/Optimal Versions/1997 - The Curse of Monkey Island/RESOURCE/VOXDISK1.BUN
Opening hashed: /home/tburke/shared/SCUMM/Games/Optimal Versions/1997 - The Curse of Monkey Island/RESOURCE/MUSDISK1.BUN
BundleMgr::decompressSampleByName() Failed finding voice 1305-D~1.IMX

I can use the period key to advance dialog (it won't progress on its own), though it will shortly either freeze in an endless loop of flushTracks() or die entirely with something like:

(52:125:0xFBE): IMuseDigital::startSound(10000)
(52:125:0xFBE): IMuseDigital::allocSlot(): All slots are full
scummvm: engines/scumm/imuse_digi/dimuse_track.cpp:61: int Scumm::IMuseDigital::allocSlot(int): Assertion `trackId != -1' failed.
Aborted (core dumped)

(exact details and timing vary). You can hit escape to bypass the cutscene, but (depending upon timing) the singing that follows may suffer from the same problem, and cannot be advanced using the period key. If done early enough, speech persists and the game is completable (presumably; will confirm tonight).

I use the uncompressed files, and was going to recopy the voxdisk2.bun and musdisk2.bun files from the CD when I checked the md5 of each file, and in both cases they matched. I suppose the CD itself may have gotten corrupted as well, but consider this a remote possibility.

Linux, x86_64 (Kubuntu)
ScummVM 0.11.0svn (Dec 9 2007 13:41:38)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2 FluidSynth
Compiled with gcc 4.1.3

And

OSX, Intel MacBook Pro
ScummVM 0.11.0svn (Dec 9 2007 18:43:10)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2
Universal image downloaded from http://worldsmainorganization.org/scummvm/

Same save game and data files work fine under 0.10.0 on same platforms.

Discussion

  • Tim

    Tim - 2007-12-11

    Save Game

     
  • Tim

    Tim - 2007-12-11
    • summary: Speech drops out, causing crash/freeze --> COMI: Speech drops out, causing crash/freeze
     
  • Filippos Karapetis

    Logged In: YES
    user_id=991970
    Originator: NO

    This does sound like a case of a bad file, but it's strange that version 0.10.0 works.

    The fact that the MD5 of the file matches doesn't guarantee that the file itself is not damaged - ScummVM calculates the MD5 of each file from the first 2000 bytes of the file (if memory serves well), not its full contents.

    Please, try recopying voxdisk2.bun and musdisk2.bun from the second CD of the game

     
  • Max Horn

    Max Horn - 2007-12-11
    • assigned_to: nobody --> aquadran
     
  • Tim

    Tim - 2007-12-11

    Logged In: YES
    user_id=1897011
    Originator: YES

    Actually, I had compared the md5 of the entire files. For the sake of completeness, I tried recopying them, but the problem persists. Same save file was used.

     
  • Max Horn

    Max Horn - 2007-12-23

    Logged In: YES
    user_id=12935
    Originator: NO

    I can reproduce this issue.

     
  • Max Horn

    Max Horn - 2007-12-23
    • priority: 5 --> 7
     
  • Max Horn

    Max Horn - 2007-12-30

    Logged In: YES
    user_id=12935
    Originator: NO

    My patch #1839861 fixes this issue.

     
  • Filippos Karapetis

    Logged In: YES
    user_id=991970
    Originator: NO

    I was able to reproduce the issue too, patch #1839861 fixed it for me as well. I believe this can be closed

     
  • Max Horn

    Max Horn - 2008-01-01

    Logged In: YES
    user_id=12935
    Originator: NO

    Patch #1839861 has been commited to trunk but (not yet?) to 0.11.0, as it is a little bit risky. But if all goes well, it will be in 0.12.0, and maybe in 0.11.1, too.

     
  • Max Horn

    Max Horn - 2008-01-01
    • assigned_to: aquadran --> fingolfin
    • status: open --> closed-fixed
     
  • Filippos Karapetis

    Logged In: YES
    user_id=991970
    Originator: NO

    I'm reopening this, as the issue still occurs for me

    If I don't skip the dialogs with ".", I get an assertion at that exact place again (where Rottingham says "You know, of course, that in a swordfight, a sharp wit is much more important than a sharp blade."). Assertion occurs at dimuse_track.cpp line 308, assert(track->soundDesc);

    Strange this is that I can ignore this assertion and the scene continues normally...

     
  • Filippos Karapetis

    • status: closed-fixed --> open-fixed
     
  • Filippos Karapetis

    Logged In: YES
    user_id=991970
    Originator: NO

    This issue has been fixed for me with commit #30310 (verified with other people from the IRC channel as well, including eriktorbjorn and Raziel^). Since I reopened this, I'm closing it again :)

    Do note though that the music stops at this point (but it did that with earlier versions of ScummVM too, e.g. 0.10.0) - this should be in a separate bug report though

     
  • Filippos Karapetis

    • status: open-fixed --> closed-fixed