RSSOwl Can't Create a Browser

Help
2011-03-28
2013-07-09
<< < 1 2 (Page 2 of 2)
  • Anonymous - 2011-07-29

    I hope to get more repositories on board in the future, so far getdeb.net
    covers Ubuntu.

     
  • genodeftest

    genodeftest - 2011-07-29

    I have no problems installing 64Bit-version from zip (or tar.gz?) file on
    Ubuntu 11.04 64bit. Did not have to change any file permissions.

     
  • CB

    CB - 2011-07-30

    @genodeftest: Did you do a fresh install? Or did you merely overwrite the
    existing installation and its folder structure with the content from the zip?

    I had done a fresh install (removed old RSSOwl version) before, that's when I
    encountered the permission issues mentioned above.

    I just tried the latter way: I installed RSSOwl 2.1.0 freshly from the
    repository, and than overwrote the installed files with the content of the
    2.1.1 zip file. Now I didn't have to correct any permissions, as no new
    folders had to be created and the pre-existing folders already had the correct
    permissions set. (Though, of course, the package manager "thinks" I still have
    RSSOwl 2.1.0 installed.)

    Sorry for spamming, just wanted to figure out why there would be
    differences...

     
  • genodeftest

    genodeftest - 2011-07-30

    I did not delete any application data (in /home/username/.rssowl2/* ) but
    renamed the RSSOwl "installation" folder in /opt and "reinstalled" RSSOwl.

    The only thing is that I have garanted me full permissions on any file in /opt
    because I otherwise RSSOwl could not update itself.

    It does not matter if I use openjdk7, openjdk6 or oracle's JDK 7.

    btw: my RSSOwl installation uses the built-in xulrunner though 1.9.2.17 is
    installed in /usr/lib

     
  • Anonymous - 2011-07-30

    I am uploading a newer version for Linux that changes the XULRunner lookup
    logic to:

    • if system property set, try that
    • if not, try without property (lookup OS default)
    • if that fails, use bundled XULRunner

    I think this will improve lookup even further. In theory someone might need to
    change settings in XULRunner and I guess this would be hard if XULRunner
    needed to be modified in the installation directory of RSSOwl which might not
    be writeable.

     
  • Bzzz

    Bzzz - 2011-08-07

    I just upgraded from 2.0x to the 2.1.1 package available from the website (ppa
    doesn't offer any newer version, nor a "natty" dist directory...)

    The xulrunner problem also occured on my system, however, I fixed it by
    renaming the bundled xulrunner directory. So, if your switch logic is already
    implemented, it doesn't work as expected ;)

    Also, please expand the faq entry a little bit. I had no idea what to do at
    this line: "Add a new startup property to rssowl named
    -Dorg.eclipse.swt.browser.XULRunnerPath=" I think it's for RSSOwl.ini, but I
    needed to google for that. It's not self-explaning.

     
  • Anonymous - 2011-08-07

    You should be able to use the getdeb.net repository, its linked from the
    download page on rssowl.org.

    I updated the FAQ entry to provide more info how to add parameters to RSSOwl.
    Its indeed odd that the lookup does not work for you, hm. What exactly happens
    when you keep the xulrunner folder and dont rename it?

     
  • Anonymous - 2011-08-07

    Actually it would help me a lot if you could do this:

    • rename the folder back to its original name (xulrunner)
    • start rssowl and try to open an article
    • export the log file (from help menu) and send it to me

    In 2.1.1 I added some extra logging.

     
  • Bzzz

    Bzzz - 2011-08-07

    Well, the following popup appears on startup:

    RSSOwl was unable to create a browser for reading news. Please refer to the
    FAQ for further help.

    Click 'Ok' to open the FAQ now.

    Actually twice, if you hit OK, it opens the help page (http://www.rssowl.org/
    help#item_6j)
    and the popup appears
    again. Clicking OK again it opens the page a second time and then rssowl
    quits.

    Getdeb repo works, I've had
    http://packages.rssowl.org/ubuntu/
    maverick main. Gee, there is a huge number of package updates available right
    now...

    okay, done updating - rssowl now starts even with the bundled xulrunner.
    Articles open without any problems. There must be some difference between the
    repo-install and the zipped file..?

    (where to put file attachments?)

     
  • Anonymous - 2011-08-07

    packages.rssowl.org is outdated, I should actually consider removing it.
    getdeb is maintained. You can post your log to pastebin.ca or send through
    mail.

    If it works fine now, fair enough. It would still be interesting what kind of
    error you get for the zipped file.

     
  • Bzzz

    Bzzz - 2011-08-07

    Yep, that's a clever idea ;)

    Todays log is here: http://pastebin.de/18142

     
  • Anonymous - 2011-08-07

    Damn, a stupid mistake. RSSOwl is indeed not testing with the OS default
    XULRunner, only when a system property is actually set. Oh well, I think this
    will make RSSOwl 2.1.2 next weekend end. Thanks for finding :)

     
  • CB

    CB - 2011-08-14

    A couple of days ago, the version of RSSOwl in the GetDeb repository for
    Ubuntu 10.04 was updated from RSSOwl 2.1-1~getdeb2 to 2.1.1-1~getdeb1. With
    this update, the installation directory was moved from /usr/share/rssowl to
    /usr/lib/rssowl. So, assuming you have Ubuntu's XULRunner 1.9.2.18 as system
    fallback (so basically, you're still using Firefox 3.6, not FF 4 or 5), you'll
    probably have to rename/move the directory /usr/lib/rssowl/xulrunner or RSSOwl
    won't start with the error as explained throughout this thread. The GetDeb
    version of RSSOwl for 10.04 doesn't seem to work with the bundled XULRunner
    version 1.9.2.17 (at least with this constellation of Ubuntu, Firefox and
    system default XULRunner versions) – no news there, only a new installation
    folder now to troubleshoot.

    Hope that helps others with this setup. :-)

     
  • Anonymous - 2011-08-15

    2.1.2 fixes the issue with the lookup, it will:

    • first check the system property if set
    • then use the OS default XULRunner
    • then use the bundled XULRunner
     
  • Bzzz

    Bzzz - 2011-09-23

    Hi,

    same problem again after upgrading to Kubuntu Oneiric Beta... ;)

    Log is here -> http://pastebin.de/18992

    First start without separate settings, second start with additional
    "-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/rssowl/xulrunner/" in
    RSSOwl.ini

     
  • Bzzz

    Bzzz - 2011-09-24

    D'oh. While digging deep in my systems config I noticed that the bundled
    version of xulrunner in the rssowl folder has some flaw:

    ./xulrunner

    run-mozilla.sh: Cannot execute ./xulrunner-bin.

    Guess what: Passed chmod +x on xulrunner-bin, and now it is working again...
    ;)

     
  • Anonymous - 2011-11-20

    hello,

    i am having exactly the same problems, although on Fedora 16 - after removing
    my old config folder (from ubuntu oneiric, where everything worked flawlessly)
    rssowl finally started up, but whenever i click on a feed i still get the
    unable to create browser message.

    log output here: http://pastebin.com/XqN6vt4d

    is there any chance to switching to xulrunner 2 anytime soon? 1.9 is terribly
    outdated and seems to cause many people problems, especially on 64 bit...

    rssowl is a great program and i'd love to continue using it - thanks!

     
  • Anonymous - 2011-11-20

    No plans to switch to XULRunner 1.9, thats out of my control. Eventually
    moving to WebKit, but right now I am not planning a new release in the near
    future.

     
  • Anonymous - 2011-11-21

    I too have been having the "Can't create browser" issue since my upgrade to
    Fedora 16. I think I have found the issue, and there is a workaround. It seems
    that xulrunner 1.9.2 is assuming there is an OS installation of libhunspell
    1.2 where Fedora 16 bundles 1.3. The easy workaround is to grab the F15
    package of libhunspell-1.2 and unpack it and place it in the xulrunner
    directory for rssowl.

     
  • Anonymous - 2011-11-22

    @Marquis42 - thanks for the hint! I tried to do what you suggested but have no
    idea how to proceed: how should I unpack the rpm? (putting the libraries
    together with the executables into the xulrunner directory doesn't help) I'd
    appreciate any help.

    @bpasero - thanks for letting me know about your plans, but do you have any
    idea how to make rssowl actually work on fedora? atm it seems that the program
    is broken on the second most popular distribution. it would be great if we
    could make this work. thanks!

     
  • Anonymous - 2011-11-22

    Sorry, atm I can not invest in support. Maybe others can jump in that have
    past experiences.

     
  • Anonymous - 2011-11-30

    @krzysztof - My apologies, I mistyped that. What I meant to say was that I put
    the lib (libhunspell-1.2.so.0) in /usr/lib64. I'm not sure why it wouldn't
    haven't worked in the xulrunner directory anyway, but it worked for me in
    /usr/lib64.

     
  • Vedran

    Vedran - 2012-01-23

    This gave me quite a headache on Fedora 16 x86_64 (to which I've upgraded from
    Fedora 15 where RSSOwl 2.1.2 worked fine).

    The problem is simple, once you get the origin of the problem: download file
    is in the zip archive, which looses permissions and xulrunner becomes
    unrunnable for ordinary users, so solutions found on the web (point 3 below)
    don't work. Here is how I've repaired the problem:

    1. Make xulrunner's executables runnable (for the xulrunner which is bundled with the RSSOwl):
      cd <your RSSOwl="" directory="">/xulrunner

    chmod 755 $(file /opt/rssowl/xulrunner/ | grep executable | sed 's/:.//')

    1. xulrunner likes to toy with the old libhunspell library, so we have to do the following nasty workaround:
      ln -s /usr/lib64/libhunspell-1.3.so.0 /usr/lib64/libhunspell-1.2.so.0

    Alternatively, you can get the old version of the libabry itself, as Marquis42
    suggested. I am not completely comfortable with that because of the possible
    unknown dependencies of the older library. I prefer risking only RSSOwl and
    not something more. Anyway, this works for now.

    1. As the user who wants to run RSSOwl, run:
      <your RSSOwl="" directory="">/xulrunner/xulrunner --register-user

    And that's it (at least it was for me).

     
  • Chris

    Chris - 2012-03-18

    First, system is Slackware64-current, using RSSOwl Version: 2.1.2, xulrunner
    version is 1.9.2.17.

    All was working well... until I upgraded KDE to 4.8.1. It was after that I
    started having problems (RSSOwl Can't Create a Browser). This was indeed
    puzzling, since I did not touch xulrunner.

    I followed the FAQ and tried several of the things mention in this tread that
    dealt with xulrunner. None of these worked.

    As it turned out it has nothing to do with xulrunner. My upgraded of KDE, also
    upgraded Hunspell from 1.2.9 to 1.3.2. This turned out to be root cause. As
    mentioned above the problem is with libhunspell.

    The work-around-fix as mentioned above is to add a symlink pointing
    libhunspell-1.2.so.0 to libhunspell-1.3.so.0.0.0:

    ln -s /usr/lib64/libhunspell-1.3.so.0.0.0 /usr/lib64/libhunspell-1.2.so.0

     
  • genodeftest

    genodeftest - 2012-03-18

    Yeah, this problem was reported in another thread here around as well. AFAIK
    libhunspell 1.2 is a dependency of XULRunner, so we need to bundle a more
    recent version of XULRunner…

     
  • Chris

    Chris - 2012-03-19

    I don't think it's xulrunner. First my xulrunner was compiled with HunSpell
    1.2.9, recompiling with 1.3.2 does not fix the problem for me.

    Before recompiling xulrunner tried starting RSSOwl with:

    RSSOwl -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/

    RSSOwl is not accepting the command line option. Looking at the About,
    Configuration Details, the option is not shown after *** System properties:

    Putting it in config.ini after results in:

    *** System properties:
    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/

    Yet the is the XULRunnerPath:

    org.eclipse.swt.browser.XULRunnerPath=/usr/lib64/RSSOwl/xulrunner

    Nothing I do will get RSSOwl to recognize the /usr/lib64/xulrunner-1.9.2.17/
    path

    Renaming /usr/lib64/RSSOwl/xulrunner/ simply breaks RSSOwl and give me the
    can't create browser dialog.

    The only thing that works is creating a symlink.

     
  • genodeftest

    genodeftest - 2012-03-19

    Did you try adding

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/
    to rssowl.ini file?

     
  • Chris

    Chris - 2012-03-19

    Yes. Read my last post.

     
  • Omega Weapon

    Omega Weapon - 2012-04-01

    uname -a: Linux 3.2.0-2-amd64 #1 SMP Tue Mar 20 18:36:37 UTC 2012 x86_64
    GNU/Linux (Debian Testing)

    Thanks to this thread I was able to get a working 64bit RSSOwl install for my
    user. I made a script out of vsego's point that the zip did not maintain the
    proper file permissions (...):

     1
     2
     3
     4
     5
     6
     7
     8
     9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    #!/bin/bash
    
    # This script is to chmod +x any executables in the given directory, no matter how nested they are
    
    # Making sure a valid directory was passed
    [[ ! -d "$1" ]] && {
        echo 'Please provide a valid directory!' > /dev/stderr
        exit 1
    }
    
    # Enabling globstar (the recursive glob)
    shopt -s globstar
    
    # Setting wordsplitting
    OIFS="$IFS"
    
    # Looping for all executable files in passed directory
    IFS=$'\n'
    for executable in $(file "$1"/** | grep executable | sed 's/:.*//')
    do
        # Checking if file isn't actually executable
        [[ ! -e $file ]] && {
    
        # It isnt - fixing
        echo "Making '$executable' executable..."
        chmod +x "$executable"
        }
    done
    
    # Restoring wordsplitting
    IFS="$OIFS"
    

    I run RSS owl in a non-standard location as I dont unmanaged non-native
    programs polluting my filesystem. Because of this, xulrunner's shared
    libraries cant be found, so I set LD_LIBRARY_PATH to the xulrunner directory
    path, e.g. testing with bash in the RSS Owl directory:

    LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl

    The next problem was the following (as mentioned by others earlier in the
    thread):

    ./xulrunner-bin: error while loading shared libraries: libhunspell-1.2.so.0:
    cannot open shared object file: No such file or directory

    I couldnt care less about spelling so I locate'd the current version of the
    library (1.3) on the system then symlinked it the xulrunner directory under
    the name it wants:

    ln -s /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 ./libhunspell-1.2.so.0

    Ran RSSOwl again and it finally worked.... hopefully the spelling library's
    interface didnt change much between the two versions ;)

    I was almost going to move to Liferea over this mess.... thanks to this thread
    I worked it out just in time.

     
  • tgutwin

    tgutwin - 2012-10-31

    Fixed same problem on Ubuntu 12.10.

    Two issues to work-around
    ~~~~~~~~~~~~~~~~~~~~~~~~~

    1. The LD_LIBRARY_PATH for the xulrunner installed in RSSOWL

      • cd to the RSSOwl Install dir then run
        • LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl
    2. It then complains about a problem with xulrunner requiring libhunspell

      • xulrunner-bin: error while loading shared libraries: libhunspell-1.2.so.0: cannot open shared object file: No such file or directory
      • Ubuntu 12.10 default package is libhunspell-1.3-0 with the correspondig library file
      • So I kludged it with a symbolic link
        • sudo ln -s /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0

    Now it works! when I run
    LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl

     
<< < 1 2 (Page 2 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks