#10 be more careful about using associate_variable

open
nobody
None
5
2012-12-15
2004-08-25
No

be more careful about using associate_variable -- it
could be either a variable or a distribution -- it
should be renamed to "owner" throughout.

attached are diffs for AbstractConditionalVariable.java
and IntegralCache.java which implement part of the
required functionality. these diffs were made in the
process of debugging a problem with handling
IndexedDistribution in lamba messages calculation. it
may be that the real problem was the presence of the
obsolete file ID_GD_D.java, so it's not clear that we
really want to apply these diffs to the production
version. still, here they are for reference.

Discussion

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks