"Error not found returned from legacy loader" failure

2013-11-07
2016-05-04
  • Paul Roodenburg

    Paul Roodenburg - 2013-11-07

    Dear Roderick,
    I am at my wits end here. I have used refind all of the last year and this year as well. I have a bootable usbstick from work with i think Ubuntu on it to be able to work remotely at home. Under Lion and mountain lion this has always worked like a charm. Just stick it in and refind finds it boot from it and away we go. Since upgrading to Mavericks this is no longer the case.

    When I start up my MBP it (USB in place) refind loads with only MacOs visible. Using esc then finds the USB but when i select the usb

    I keep getting the following error:

    Error: not found returned from Legacy loader
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: not found from LocateDevicePath
    Error: Load error while (re)opening our installation volume

    After that Refind cannot boot Macos either and I have to turn the mbp off to be able to boot macos again.

    The above happens with all Refind versions all the way back to 0.4.0. (while installing them by dragging the install.sh script into the terminal window)

    I have tried installing Refind with --alldrivers as well (again multiple versions) but to no avail. The only change is that refind displays the USB on the first load without me having to use the esc button. I still keep getting this error.

    Finally I tried installing some of the bin-gneu builds but this didn't solve the problem either.

    I am using a Macbook pro mid 2009 with a Samsung evo 256gb SSD with Mavericks 10.9

    The USB still functions flawlessly on windows systems (but using your neighbours computer to test it is one thing to claim his computer for whole days to work is another ;-))

    Problem is that I cannot do anything with the USB stick as it is provided by the company and I am not allowed or able to temper with it.

    I am pretty much a noob when it comes to this and I have exhausted my capabilities. I hope that you might have an answer.

     
  • Roderick W. Smith

    As rEFInd runs before OS X, it's odd that an OS X upgrade could cause rEFInd to malfunction -- none of the changes to OS X should affect rEFInd. I have two guesses about the cause:

    • In the process of upgrading OS X, changes were written to the computer's NVRAM/PRAM which disrupted rEFInd's ability to launch a legacy OS. In this case, resetting the NVRAM/PRAM may fix the problem.
    • The OS X upgrade may have included a firmware upgrade, and the new firmware has a bug (or at least a change from previous behavior) that's causing the problem. In this case, downgrading to an older version of the firmware might fix the problem.

    The first of these solutions is likely to be less risky. In either case, there's a good chance that you'll need to re-install rEFInd, or at least re-bless it (via the OS X bless utility).

    If these options fail or if they seem to be too radical, another possible workaround is to abandon BIOS/legacy-mode booting of your USB flash drive. Instead, copy the kernel and initial RAM disk from that flash drive to your hard disk (or even to another USB flash drive). In Linux, the kernel will be called /boot/vmlinuz*, and the initial RAM disk will be /boot/init*. Put these files in the root (/) directory or /boot directory of any FAT or HFS+ partition on the disk. Also, create a refind_linux.conf file in the same location as the kernel, as described near the bottom of this page. When you reboot with these changes, you should see a new option for booting Linux via the vmlinuz* file. If you've set up the refind_linux.conf file, it should boot Linux in EFI mode.

     
  • Paul Roodenburg

    Paul Roodenburg - 2013-11-08

    Dear Roderick,

    Thanks very much for your response. I tried your first suggestion and this did not work.
    Option 2 is not the case because i checked the EFI firmware and that has not been changed since 2009. And the last option is not possible because of the protection installed by the IT department of my firm. :( So I will be taking my laptop to them to see if they can try and fix it.

     
  • Roderick W. Smith

    If your Ubuntu uses a 3.3.0 or later kernel, you might be able to get it to boot by installing an EFI filesystem driver (included with rEFInd) for whatever filesystem you're using on the USB flash drive. You might also need a refind_linux.conf file in the directory that holds your kernel, though. (Whether this would be required depends on how it's partitioned and otherwise set up.) This should enable rEFInd to boot the USB flash drive's kernel directly in EFI mode, much as it would if you were to copy the kernel to your ESP or some other directory.

     
  • Justin

    Justin - 2015-02-05

    I am also receiving this message.
    MacBook 3,1
    OSX 10.7.5
    Installed Tails 1.2.3 on Sandisk Cruzer Glide 16gb flash drive according to website instructions
    Installed rEFInd 0.8.5, runs perfectly
    Tried to boot from USB, and receive the error message in the above post

    Has anyone found a fix for this since 2013? Is it the computer, OS, flash drive or software?
    Is there an alternative to running Tails in relation to using Tor Browser? I like the amnesiac quality, but I'm a novice user who just browses.

    Any help would be appreciated. Thanks.

     
  • Justin

    Justin - 2015-02-06

    Never mind. It's the USB.

     
  • Roderick W. Smith

    I'm glad you found a solution. As it happens, I just tried it out myself and discovered that a "manually-installed" Tails boots fine on both a 64-bit MacBook Air and an old 32-bit Mac mini.

    On the other hand, a version of Tails made with the Tails Installer boots fine in EFI mode on a 64-bit MacBook Air but fails to boot in BIOS mode on both that same MacBook Air and on my 32-bit Mac Mini. (Tails lacks a 32-bit EFI boot loader. I suspect it might be made to work in 32-bit mode by launching from Linux using also_scan_dirs live in refind.conf, but my one attempt at this hung. Maybe adding the right kernel options would work.)

    FWIW, the EFI loader has an icon in rEFInd:

    http://www.rodsbooks.com/screenshot_001.png

     
  • crhoads1024

    crhoads1024 - 2015-03-23

    Running into similar but not exact issue.

    Kali 1.1.0 on new MacBook Air purchased 3/20/2015 - OS X Yosemite 10.10.2
    Refind installed
    Using a Live USB DD'd with kali 1.1.0 verified iso per instructions from kali officail site.

    When the system boots into rEFInd I'm seeing the following error depending on which USB device that is recognized I choose to boot from

    The one that appears in the middle: Boot EFI\BOOT\syslinux.efi from 62 MiB FAT Volume
    rEFInd - Booting OS

    Starting syslinux.efi
    Using load options ' '

    This MacBook Air is unresponsive and I am required to hold down left shift key + ctrl + cmd + Power and release at the same time. The system essentially bricks everytime it tries to load off the usb straight out of the gate or with this rEFInd option.

    The second rEFInd discovered boot option is chosen: Boot Legacy OS From whole disk volume
    Starting legacy loader
    Using load options 'USB'
    ERROR: Not Found while loading legacy loader

    Please make sure that you have the latest firmware update installed

    Hit any key to continue

    Tried initially on a SanDisk Cruze til I found this thread then tried a diff usb stick and got the same issue.

    Beating head against wall all weekend....
    Any and all help is greatly appreciated!

     
  • crhoads1024

    crhoads1024 - 2015-03-24

    Took same USB and put it in my Mac Mini and the mac Mini booted with the USB just fine. The mac mini was purchased Dec 2014 so I don't know if it is the form factor, or the firmware or what but it works with this configuration but not not he MacBook Air configuration and it was purchased 3/16/2015.

    This one works!!!
    Model Name: Mac mini
    Model Identifier: Macmini7,1
    Processor Name: Intel Core i5
    Processor Speed: 1.4 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 4 GB
    Boot ROM Version: MM71.0220.B01
    SMC Version (system): 2.24f32

    This one does NOT!
    Model Name: MacBook Air
    Model Identifier: MacBookAir7,2
    Processor Name: Intel Core i5
    Processor Speed: 1.6 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 8 GB
    Boot ROM Version: MBA71.0166.B00
    SMC Version (system): 2.27f1

    I am going to try to just feed the macbook air the same BOOT ROM Version and see what happens

     
  • Roderick W. Smith

    The form factor per se is irrelevant. Any differences you're seeing are most likely caused by firmware differences. (It could be that CPU differences or a defect in the USB interface could cause problems, but that's unlikely.)

    You might try creating the flash drive in a different way. In most cases, using dd is the best way to go; but a dd-created USB flash drive may be a bit of a Frankenstein's monster, and might confuse some EFIs. Thus, using something like unetbootin might work better. You may need to explicitly select an EFI-boot option in such tools, though. (I don't recall offhand if unetbootin specifically includes such options, but I've seen options for EFI booting in some such tools.)

     
  • Tomas Bond

    Tomas Bond - 2015-05-31

    Im getting this error trying to boot ubuntu 14.04 from USB stick (i made it with unetbootin). Tried different usb booting software, different sticks, different OS versions (14.04 and 6.10). Nothing seems to fix the error. Need to boot from USB to install Linux on a Macbook pro 2,1 (2006). Cant boot from DVD, the machine continues to refuse on reading the Linux live cd.

    OSX version: 10.6 (out of the box)
    EFI SPECIFICATION REVISION:1.10
    EFI VENDOR: APPLE
    EFI REVISION: 4096.1
    EFI BUILD VERSION : 20070328

     
    Last edit: Tomas Bond 2015-05-31
  • Roderick W. Smith

    Tomas:

    First, be sure you're using the latest rEFInd (0.8.7 as I write).

    Second, try using different software to create your USB flash drive. Every tool (dd, unetbootin, etc.) does things a bit differently, and some of them do things in ways that may freak out some EFIs -- potentially including some or all Apple EFIs.

    Finally, rEFInd is likely to show two options for at least some Linux installation media. One (which will likely provide a filename in its description, and may show a distribution-specific icon) boots in EFI mode. The other (which may refer to a legacy loader and will probably show a generic Tux penguin icon) boots in BIOS mode. You can install using either boot mode, although there are caveats and subtle differences between them. Thus, if one boot mode doesn't work, it's worth trying the other one.

     
  • Brad

    Brad - 2015-06-15

    Same issue with a Windows 7 USB installer. Works fine with a late 2011 Macbook Air. Refuses to boot on a new 2015 Macbook Air. running refind 0.8.7, legacy bootloader is invoked, get "Error: not found while loading legacy loader".

    Same exact behavior with a Debian Jessie USB installer.

    Why is it using the legacy loader anyway?

    thanks Rod in advance.

     
    Last edit: Brad 2015-06-15
  • Roderick W. Smith

    Installing Windows 7 in EFI mode on a Mac is tricky at best. Few people have succeeded. I used to have a long thread about this on a Mac forum bookmarked, but I've lost that bookmark.

    Installing Windows 8.x in EFI mode is much more likely to succeed. Despite my own aversion to Windows 8, this might be the way to go, simply to avoid all the legacy-mode and hybrid MBR complications. Googling "Windows 8 EFI Macintosh" or something like that turns up a bunch of hits on this subject. Note that I don't run Windows on either of my Macs, so I can't really help much on the details of how to do such an installation.

    For Debian, if the USB drive includes an EFI/BOOT/bootx64.efi file (or bootia32.efi for Macs with 32-bit EFIs), rEFInd should pick that up and offer it as an option. In some cases, though, the Mac's EFI might be confused by bizarre disk formats, which you can get when you prepare the disk in certain ways. A dd copy of the .iso file is particularly likely to confuse the EFI. Thus, you might want to try another USB-creation tool.

    If rEFInd isn't working, you can always try the Mac's built-in boot manager. It's activated by holding down Option (or Alt on a PC-style keyboard) while you boot. If that doesn't work, then either there's something wrong with the USB drive (physically or its contents) or it's simply something that your model Mac can't boot because of firmware incompatibilities.

    I'm afraid that booting external media on Macs is particularly troublesome. I don't claim to know the reasons, except that Apple seems to have changed its firmware multiple times, which makes it difficult for anybody with a budget of less than tens or hundreds of thousands of dollars for purchasing test machines, and lots of time to experiment, to figure out.

     
  • Apple Techy

    Apple Techy - 2016-04-29

    I am a little late to the party here but I don't see a definitive solution. I am able to succesfully run rEFInd 0.10.3 but when I try to boot a Kali V2.0 USB drive I see the " Error: Not Found from LocateDevicePath / Error: Load Error while (re)opening our installation volume". I have tried on a Lexar 16gb 3.0 drive as the boot media. I installed the os using the dd method on my iMac. The computer I am running rEFInd on is a Macbook 2009 with a Model Number of A1181. Any help would be much appreciated as I am trying to breath new life into this laptop! :)

    Edit: After using Mac Linux USB Loader by Sevenbits I was able to get rEFInd to boot from the drive even though there are a couple errors, it was still able to boot.

     
    Last edit: Apple Techy 2016-05-07
  • Roderick W. Smith

    If you're running Kali, I recommend trying to get it to boot in EFI mode rather than use BIOS/CSM/legacy-mode booting, which tends to be a bit flakier for Linux. I don't use Kali, so I can't offer Kali-specific recommendations. You may get more specific advice on a Kali forum.

     

Log in to post a comment.