#83 ideal transformer

0.0.17
closed-invalid
None
5
2013-06-20
2012-02-20
No

Hi QUCS developer!

The ideal transformers (both under "lumped components") in version 0.0.15 work.
However, they do not work in version 0.0.16!

Thomas

Related

Bugs: #83
Bugs: #99

Discussion

  •  magneto98

    magneto98 - 2012-02-20

    Hello Thomas,

    could you provide more details and an example schematic?

    Carsten

     
  • Thomas Bechteler

    Hi Carsten!

    The schematic is quite simple: Just an ac source (sinusoidal, 1V, 50Hz)
    connected to the ideal transformer's input, and the transformer's output is connected
    to a resistor (1k). Transient analysis (0-50ms, 1001 steps). The input voltage is there, but the output is zero.

    This is the case for QUCS under SuSE11.1 and under Windoze.

    I tested an ac analysis (frequency sweep), and this works fine in all versions.
    It seems to be the transient analysis which causes problems.

    Actually, I wanted to simulate a simple diode rectifier (half-wave and full-wave),
    however, with the same result. To demonstrate QUCS to my students, I work around
    with "mutual inductors" (turn ratio = sqrt(L1/L2) and k = 0.99).

    Cheers

    Thomas

     
  • m4v

    m4v - 2012-09-16

    I can confirm, somebody in the qucs-help list had this problem. You can see it with this test circuit, plotting Vout shows a flat line.

    <Qucs Schematic 0.0.16><Properties>
    <View=0,0,800,800,1,0,0>
    <Grid=10,10,1>
    <DataSet=2.dat>
    <DataDisplay=2.dpl>
    <OpenDisplay=1>
    <Script=2.m>
    <RunScript=0>
    <showFrame=0>
    <FrameText0=T\x00EDtulo>
    <FrameText1=Dibujado por:>
    <FrameText2=Fecha:>
    <FrameText3=Revisi\x00F3n:>
    </Properties>
    <Symbol>
    </Symbol>
    <Components>
    <R R1 1 470 270 15 -26 0 1 "50 Ohm" 1 "26.85" 0 "0.0" 0 "0.0" 0 "26.85" 0 "european" 0>
    <Tr Tr1 1 300 270 -29 38 0 0 "1" 1>
    <GND * 1 470 300 0 0 0 0>
    <Vac V1 1 140 270 18 -26 0 1 "1 V" 1 "100 Hz" 0 "0" 0 "0" 0>
    <.TR TR1 1 150 420 0 65 0 0 "lin" 1 "0" 1 "0.01" 1 "101" 0 "Trapezoidal" 0 "2" 0 "1 ns" 0 "1e-16" 0 "150" 0 "0.001" 0 "1 pA" 0 "1 uV" 0 "26.85" 0 "1e-3" 0 "1e-6" 0 "1" 0 "CroutLU" 0 "no" 0 "yes" 0 "0" 0>
    <VProbe Vin 1 220 140 28 -31 0 0>
    </Components>
    <Wires>
    <330 300 470 300 "" 0 0 0 "">
    <330 240 470 240 "" 0 0 0 "">
    <270 300 270 360 "" 0 0 0 "">
    <140 300 140 360 "" 0 0 0 "">
    <140 360 230 360 "" 0 0 0 "">
    <270 200 270 240 "" 0 0 0 "">
    <140 200 140 240 "" 0 0 0 "">
    <140 200 210 200 "" 0 0 0 "">
    <210 200 270 200 "" 0 0 0 "">
    <210 160 210 200 "" 0 0 0 "">
    <230 360 270 360 "" 0 0 0 "">
    <230 160 230 360 "" 0 0 0 "">
    <470 240 470 240 "Vout" 480 200 0 "">
    </Wires>
    <Diagrams>
    </Diagrams>
    <Paintings>
    </Paintings>

     
  • NguyenV

    NguyenV - 2012-11-06

    Hi,

    I appreciate a lot Qucs for personal works or teatching purposes but...

    the question is the same as Thomas :

    What's new about ideal transformer ?

    The ideal transformer works in version 0.0.15 but not in version 0.0.16 under Windows 7.

    I test the supply schematic "supply.sch" given in http://qucs.sourceforge.net/examples.html

    Furthermore the symmetrical transformer seems to not work in version 0.0.15 ?

    Many thanks !

     
  • NguyenV

    NguyenV - 2012-11-14

    For those who have an interest with this bug.

    Found this "distrib" of Qucs which works perfectly with Windows 7 with ideal (symmetrical or not) transformer :

    http://www.mydarc.de/dd6um/QucsStudio/qucsstudio.html

     
  • Frans

    Frans - 2013-06-06

    Could you try our latest qucs development snapshots? does the transformer work there?

     
  • Richard C

    Richard C - 2013-06-07

    I will investigate this today.

    On 06/06/2013 21:40, Frans wrote:

    Could you try our latest qucs development snapshots? does the
    transformer work there?


    [bugs:#83] http://sourceforge.net/p/qucs/bugs/83/ ideal transformer

    Status: open
    Created: Mon Feb 20, 2012 01:30 PM UTC by Thomas Bechteler
    Last Updated: Sat Dec 15, 2012 03:09 PM UTC
    Owner: nobody

    Hi QUCS developer!

    The ideal transformers (both under "lumped components") in version
    0.0.15 work.
    However, they do not work in version 0.0.16!

    Thomas


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/qucs/bugs/83/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #83

  • Frans

    Frans - 2013-06-07

    Great!

    On 7-6-2013 10:38, Richard C wrote:

    I will investigate this today.

    On 06/06/2013 21:40, Frans wrote:

    Could you try our latest qucs development snapshots? does the
    transformer work there?
    
    ------------------------------------------------------------------------
    
    /[bugs:#83] <http://sourceforge.net/p/qucs/bugs/83/>
    http://sourceforge.net/p/qucs/bugs/83/ ideal transformer/
    
    /Status:/ open
    /Created:/ Mon Feb 20, 2012 01:30 PM UTC by Thomas Bechteler
    /Last Updated:/ Sat Dec 15, 2012 03:09 PM UTC
    /Owner:/ nobody
    
    Hi QUCS developer!
    
    The ideal transformers (both under "lumped components") in version
    0.0.15 work.
    However, they do not work in version 0.0.16!
    
    Thomas
    
    ------------------------------------------------------------------------
    
    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/qucs/bugs/83/
    
    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/
    

    [bugs:#83] http://sourceforge.net/p/qucs/bugs/83/ ideal transformer

    Status: open
    Created: Mon Feb 20, 2012 01:30 PM UTC by Thomas Bechteler
    Last Updated: Thu Jun 06, 2013 08:40 PM UTC
    Owner: nobody

    Hi QUCS developer!

    The ideal transformers (both under "lumped components") in version
    0.0.15 work.
    However, they do not work in version 0.0.16!

    Thomas


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/qucs/bugs/83/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #83

  • Richard C

    Richard C - 2013-06-07
    • assigned_to: Richard C
    • Group: --> v1.0_(example)
     
  • Richard C

    Richard C - 2013-06-07

    Having investigated this, I think there is not a bug after all, and instead there is a misunderstanding of what the ideal transformer component actually does.

    The ideal transformer acts as a perfect current transformer, the current in the primary is mutiplied on the secondary. If you just put a voltage source across the terminals, it acts like a short circuit, so there is infinite current. At the same time in this case, there is no resistance, and therefore no voltage drop across the tranformer inputs, hence the output voltage is also zero.

    See here for more information:

    http://qucs.sourceforge.net/tech/node48.html

    The ideal transformer component does not reflect a real physical transformer device, a real device must have winding resistance and inductance, and only works with AC voltages. An ideal transformer can transform DC current, which is physically impossible in the real world (maybe some exotic superconducting device I'm not aware of).

    What changed in Qucs 0.0.15 -> 0.0.16 as far as I can tell was that the behaviour was actually corrected for DC simulation.

     
  • Richard C

    Richard C - 2013-06-07
    • status: open --> closed-invalid
     
  • Richard C

    Richard C - 2013-06-07

    As in my last post on this bug, there is no bug.

     
  • Frans

    Frans - 2013-06-07

    <html>
    <head>
    <meta content="text/html; charset=ISO-8859-1" http-equiv="Content-Type">
    </head>
    <body text="#000000" bgcolor="#FFFFFF">
    Good! another bug to close



    On 07-06-13 18:00, Richard C wrote:




    As in my last post on this bug, there is no bug.




    [bugs:#83]
    ideal transformer


    Status: closed-invalid

    Created: Mon Feb 20, 2012 01:30 PM UTC by
    Thomas Bechteler

    Last Updated: Fri Jun 07, 2013 03:57 PM UTC

    Owner: Richard C


    Hi QUCS developer!


    The ideal transformers (both under "lumped components") in
    version 0.0.15 work.

    However, they do not work in version 0.0.16!


    Thomas




    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/qucs/bugs/83/


    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/






    </body>
    </html>

     

    Related

    Bugs: #83

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks