#91 malloc.h has been deprecated

GLE (4)

malloc.h has been deprecated on at least one platform
(FreeBSD). Ocurrences need to be wrapped such that
they use stdlib.h if available.


  • Mike C. Fletcher

    • labels: --> GLE
    • milestone: --> v2.0.1
    • priority: 5 --> 4
    • assigned_to: nobody --> mcfletch
  • Mike C. Fletcher

    Logged In: YES

    Hmm, all instances of this are in third-party modules (we
    use Python's malloc for PyOpenGL itself). I'm hesitant to
    start messing around with Togl and GLE code, as we currently
    just build the respective project's trees without modification.

    Is this actually stopping the build, or generating warnings?
    I'd be inclined to leave put in bug reports to the two
    other projects and let them decide how to deal with the
    issue rather than maintaining a patch set for them.

    Note: We're currently using an older version of GLE, should
    try upgrading and seeing if that fixes the problem in the
    GLE modules. We're using the CVS version of Togl, so it's
    definitely still a problem there.

  • Andrew P. Lentvorski, Jr.

    Logged In: YES

    This actually completely stops a build under



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks