#154 [list-len] uses [list length], which doesn't exist in 0.39

v0.39.2
closed-fixed
7
2007-06-16
2007-06-13
No

In Pd-0.39.2-extended-rc2, list-abs/list-len uses [list length], which does not exist in 0.39 at all. It was introduced in 0.40. Therefore, list-len does not work.

(it would be good to look for other 0.40isms that were included in the backport of the list-abs to 0.39.2)

Discussion

  • Logged In: YES
    user_id=569446
    Originator: NO

    Actually I have fixed this in the branch "branch-v0-39-2-extended" five days ago by reverting to a previous version, so it should be okay automatically fixed for the next pd-extended release.

    Sorry for introducing this bug in the first place.

     
  • Logged In: YES
    user_id=569446
    Originator: NO

    Additional note: I found out, that last week I forgot to check in a similar fix for another patch that was using [list length]: list-compare.pd The 0.39 version is checked in now.

    Should I close this bug or would you prefer to keep it open until pd-ext rc3/final?

     
  • stffn
    stffn
    2007-06-16

    Logged In: YES
    user_id=1658640
    Originator: NO

    Both list-len and list-compare work here in RC3.

    (os x.4.9, macbook core duo)

     
  • Logged In: YES
    user_id=569446
    Originator: NO

    Thanks for testing, stffn.

    Then it's fixed in pd-ext RC3 on all platforms, as it's just about abstractions.

     
    • status: open --> closed-fixed
     


Anonymous


Cancel   Add attachments