Unable to run ps-watcher as daemon locally
Brought to you by:
rockyb
I've installed ps-watcher under /user/foo/.local, since I'd rather not give the app root permission. When running the app locally, it tries to create "/var/run/ps-watcher.pid" instead of in /user/foo/.local where it has permissions.
Running:
/home/users/foo/.local/bin/ps-watcher
with the following command:
ps-watcher --config /home/users/foo/daemon.ini --log /home/users/foo/ps-watcher.log
Anonymous
In git I have just changed things so that you can both configure the default filename to use as a pidfile (--with-pidfile /var/run/ps-watcher.pid, see configure --help for all options). Also there is a new ps-watcher option --pidfile which lets you specify where to store the PID.
Between these two I think that should do the trick. I have not tested this extensively. Please try it out.