#4 Run/Debug hint throws exceptions


I was experimenting with the extension, but I tried to do some non-prolog work in Eclipse (more specifically Plugin development), and when I tried to Run my project using the Run button, I got an exception from the eclipse system.

I attach an error log extracted from eclipse, I hope it helps locating the cause of the error. I would like to have this error fixed, but I do not have the resources/required knowledge to do it.

If you need further details, tests, I'm glad to help.

Thank you,


  • Zoltán Ujhelyi

    Zoltán Ujhelyi - 2008-09-24

    Eclipse Error log about the error

  • Claudio Cancinos

    First of all let me tell you It'll be very difficult to me to test it in your enviroment since I don't have a VM running a mac osx :(

    But maybe we don't need it, because as far as I can see in the log, it is an error when eclipse is trying lo load one of ProDT's plugins. Specifically the one in ar.com.tadp.prolog.jar.
    Since you have been experimenting with ProDT and at least some of its functionality worked I guess you have it correctly installed in your eclipse. If it didn't work you might check if the jar files were not corrupted when you downloaded them.

    If the jar files are ok on your eclipse, you might try launching eclipse with -clean as parameter.

    mmm... unfortunatelly at the moment I don't think I have any other options, because this error is not caused by the prolog plugins execution, but by its loading on the JVM by eclipse.

    Please let me know if any of these suggestions help you.

    Claudio Cancinos

  • Zoltán Ujhelyi

    Zoltán Ujhelyi - 2008-09-27

    I had some problems this week with the installed packages (which I did not notice before filling in this bug report). It took some time to have the P2 installer to install every package correctly (again :) ).

    After that I uninstalled ProDT (removed from my dropins folder), redownloaded it and installed it again.

    Now it seems like working - but I am not entirely sure about it. I need some time to test it.

    But thanks for your help,

  • Claudio Cancinos

    • status: open --> closed
  • Zoltán Ujhelyi

    Zoltán Ujhelyi - 2008-10-09
    • status: closed --> open
  • Zoltán Ujhelyi

    Zoltán Ujhelyi - 2008-10-09

    It is quite interesting: after uninstalling and reinstalling the plugin (removing from the dropins, restarting, putting it to the dropins, restarting eclipse) I got the plugin working - for a while.

    This issue comes repeatedly, and is quite embarassing. I do not have any idea, what might have caused it, but I would like to get some help debugging it.

    Thank you,


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks