#5 OS X rndr requires libtiff v11 but latest libtiff is v3.6.1

open
nobody
5
2006-10-21
2006-10-21
hawkshadow
No

Just installed OS X PowerPC Pixie binary on OS X v
10.4.8 and libtiff from the latest version of Fink
(Package manager version 0.24.17, distribution version
0.8.1. The version number of libtiff is 3.6.1-4. When I
run the Pixie renderer I get the following message:

dyld: Library not loaded: /sw/lib/libtiff.3.dylib
Referenced from: /Applications/Graphics/Pixie/bin/rndr
Reason: Incompatible library version: rndr requires
version 11.0.0 or later, but libtiff.3.dylib provides
version 3.6.0
Trace/BPT trap

Discussion

  • hawkshadow

    hawkshadow - 2006-10-24

    Logged In: YES
    user_id=1626490

    I found a workaround that no longer works in a bug filed on
    this issue in 2005 (artifact id 1265790). That workaround
    said to install the unstable tip of the libtiff tree,
    however, the version reporting problem has been fixed in
    libtiff since Pixie was compiled on OS X, so the latest
    version of libtiff no longer works with Pixie. I either need
    a version of libtiff that works with Pixie, or a Mac OS X
    compile of Pixie with the latest libtiff.

     
  • Romuald Perrot

    Romuald Perrot - 2006-12-09

    Logged In: YES
    user_id=1505391
    Originator: NO

    If you want the correct version, you have to install the libtiff library from unstable fink package.

    You can also download and install latest libtiff from the official site, it also works.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks