Compiling on OSX under Intel processors

Help
JasonBelec
2007-03-29
2013-04-25
  • JasonBelec

    JasonBelec - 2007-03-29

    OK, thought this new version of Pixie looked to be very impressive.

    Problem: Compile following the instructions works fine until....

    checking tiffio.h usability... no
    checking tiffio.h presence... no
    checking for tiffio.h... no
    configure: error: tiffio.h not found

    Now that is the latest and it is installed as per the instructions.

    Any ideas, while I try to hack around the issue?

     
    • Nicholas Yue

      Nicholas Yue - 2007-03-30

      Hi Jason,

        You can specify additional location to find include and libary files via CXXFLAGS and LDFLAGS environmet variable

        If you have tiff from non-standard source (like I got my TIFF from Darwin Ports rather than Fink), I do something like

              env CXXFLAGS=-I/opt/local/include LDFLAGS=-L/opt/local/lib ./configure ........

        Hope that helps but I have only done the above for OS X on PPC, not Intel, but I believe they should work.

      Regards

       
    • JasonBelec

      JasonBelec - 2007-03-30

      Hello Nicholas, appreciate the insight. Tried several variations that I recieved by email and yours all ran and ended the same way. The file in question exists, is in the proper location and the latest. However it is not recognized. Interesting as I have had this work on the old G4 Cube in the past.

      Perhaps a better explanation...

      Macintosh HD>sw>bin
                      etc
                      fink
                      include>tiffio.h
                      lib
                      sbin
                      share
                      src
                      var

      So taking your approach...

       
    • JasonBelec

      JasonBelec - 2007-03-30

      OK, tried several more option sincluding opening Fink up to unstabble branches. Nothing seems to regnize the tiffio.h file, not even locate. Spotlight does see it, weirder.

      So I manually installed the latest Libtiff files, that allowed tiffio.h to be recognized for configure, but threw up a gazillion errors for make. Tried several configure suggestions.

      So I removed that as well.

      Anyone get things working under MacOSX Intel? Know anyone? Know sombody, who knows somebody, thats a sometimes friend?

      Thanks anyway, will keep searching the web for similar issues...

       
      • George Harker

        George Harker - 2007-03-30

        I'm not sure why this would be occurring.  The fink version installed is for intel (not pulled from a PPC machine)?

        Here's how I do my builds (assuming tcsh):

        Be careful because it's referencing an OpenEXR path in my home directory.  You can either replace the path (assuming you've got a static openexr built somewhere) or replace the configure line with

        ./configure --prefix=${PIXIE_INSTALL_LOC} --enable-selfcontained --enable-static-fltk

        and omit the OpenEXR display driver from the build

        ## Ensure fink gets searched

        setenv CPATH /sw/include/
        setenv LIBRARY_PATH /sw/lib/

        ## Where to?

        set PIXIE_INSTALL_LOC = /Applications/Graphics/Pixie/

        ## Optimizations

        setenv CXXFLAGS '-g -O3  -falign-loops=16'

        ## Standard Includes
        setenv CPPFLAGS "-I/usr/X11R6/include -I/sw/include"

        ## Build it
        ./configure --prefix=${PIXIE_INSTALL_LOC} --enable-selfcontained \     --with-openexr-prefix=/Users/geohar/Development/OpenEXR/prefix/ --enable-static-openexr --enable-openexr-threads \     --enable-static-fltk   
        make install

        Hope that helps

        George

         
        • NeoReel

          NeoReel - 2007-03-30

          Thanks for your reply!

            Fact is that I want to compile on a Command Line environment, for renderfarm machines. So I don't have any FLTK, openEXR or X11 libraries installed (they are optional anyways).
            The "./configure" works correctly, but the "make" eat up all the memory...

            I'm currently trying to increase the swap partition... We'll see if a couple of gigs will have it compile.

          M-A

           
          • George Harker

            George Harker - 2007-03-30

            The compilation of execute.cpp and stochastic.cpp usually takes a long time (and lots of memory).

            The idea here is to burn time at compile phase which means we get tight, fast code at runtime.

            Sadly certain gcc versions have some memory bugs which mean they don't limp through the compile, they simply bail out.

            This page

            http://www.george-graphics.co.uk/pixiewiki/Compiler_Versions

            Has some info on various OS / compiler versions people have used.  It may be a little bit out of date, but if you could add details there for your setup, that would be great.

            Do the precompiled releases not work for you, or are you trying to get a 64bit build done?

            Thanks

            George

             
    • JasonBelec

      JasonBelec - 2007-03-30

      Well I appreciate your time as always George.

      Still getting the error on make install, several hundred lines so I won't post them.

      Going to go back to square one and re-install everything step by step, perhaps I made a mistake and just refused to acknowledge it.

       
    • JasonBelec

      JasonBelec - 2007-03-31

      Well I went through the entire process again only to get stopped at the same thing 'tiffio.h' can't be found and yet it is present. Everything else builds beautifully, tests work as expected. I'm going to try something a little more creative.

      But first, I downloaded the binary to try a few things, but this is still an issue when working with tools. If it works, it works. If it only works in some environments, and perhaps in others with certain steps taken, then more detail needs to be worked out. Or more instructions.

      If it's really just me, then by all means give me a bloody nose.

      On the other part of this, I understand the idea behind the compiling upfront to make for efficiencies, but I have done other apps this way and not seen this kind of space hogging. In fact wouldn't it be better to evaluate what a system has and work in a safe margin. Better to take longer to compile than not compile at all. No way exists with the last few builds to compile on the renderfarm, as memory and space is not enough with the last few builds. So we had to build a box to do a cross compile under FC5 and this works, but I feel for others without resources.

      All that said, long live Pixie!!

      Again, I appreciate your input and knowledge George as you have been a great help.

      Jason

       
      • George Harker

        George Harker - 2007-03-31

        Hi Jason,

        I understand your frustration, but there are good reasons why execute.cpp is written the way it is - we may alter it in the future, but right now it's not likely to change.  The real issue is that there are a couple of commonly found gcc releases which have a serious memory handling bug.  I'm not pointing fingers, it's just the way it is - have a look to the gcc bug tracker.

        I know the compiler versions page is skewed - it appears there are lots of combinations that don't work.  Unfortunately folks tend to report only the non-working ones.  I know Pixie works successfully with:

        OSX 10.4 PPC / gcc4.0.1 (apple release)
        OSX 10.4 intel / gcc4.0.1 (apple release)
        Fedora Core 3 / gcc4.0.2
        Fedora Core 6 / (forgive me I forget which version of gcc)
        Suse (again not sure of the compiler version)

        I'd love to get a full list - please add to the compiler versions page if you compiled yourself (successfully or otherwise).

        Did you try the intel OSX precompiled releases? 

        In terms of the the tiffio issue, I'm having trouble coming up with a reason for it not being found, especially if it's present.

        A few points to check:

        You've got fink installed, and installed libtiff, libtiff-shlibs.
        Your fink prefix is the standard one (/sw/) and you've got a non-blank file, tiffio.h at /sw/include/tiffio.h
        You ran all the commands in the previous post, in one shell with no errors (other than configure bailing out).

        _This is important_  - in particular, if you do not do the following lines

        setenv CPATH /sw/include/
        setenv LIBRARY_PATH /sw/lib/

        or include this

        CPPFLAGS=-I/sw/include LDFLAGS=-L/sw/lib/

        on the end of your ./configure line ie

        /configure --prefix=/Applications/Graphics/Pixie --enable-selfcontained CPPFLAGS=-I/sw/include/ LDFLAGS=-L/sw/lib/

        then tiffio.h will not be found. 

        If it can be done in a sensible way, I'll have the configure script try to guess the right places to look.

        Cheers

        George

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks