OpenServer throws NoNe SuCh=: is not an ide

  • b.c.s.i.

    b.c.s.i. - 2008-01-07

    I installed the latest version on a SCO OpenServer 5.0.7 machine, and set a user and password.

    When I run the program I can log in, get a command prompt and change directories but whenever I try to run a command I get:

    NoNe  SuCh=: is not an identifier

    My phpinfo() shows:

    _ENV["NoNe__SuCh"]    no value

    I have no idea what this is or what this should be set to.

    Any ideas or comments?


    (I accidentally post this same message into the open discussion forum, sorry).

    • bzrudi

      bzrudi - 2008-01-08

      Hi bcsi,

      I did not maintain phpterm for a while and there is a new fork ajaxphpterm, which may fix your issues. If not feel free to get bak so we can get rid of it. Even if I don't know this issue  ;-)

      cheers bzrudi

      • b.c.s.i.

        b.c.s.i. - 2008-01-09

        Wow, that was a quick response!

        After I posted this message and did some (ok, a lot) of Googling I found the ajaxphpterm product which I quickly downloaded and tested. It throws the same error message.

        I also installed ajaxphpterm under Mandriva 2008 and low and behold it worked! I don't know if it will do what I want it to do but at least it didn't throw any errors.

        Ok, so what are the differences?

        Well, the biggest difference, other than the UNIX / Linux one was that Linux was running php 5 and SCO was running PHP 4 and I bet that's the problem.

        Unfortunately I can't find a build of Apache/MySQL/PHP5 for SCO OpenServer 5.0.7. I know I could try compiling everything myself from scratch but right now I don't have the time (I'm not that good at compiling C code) especially since I don't know that doing so will fix the problem.

        Maybe if you confirm that IS the problem I'd be more motivated :-)

        Any and all comments or suggestions are appreciated.


        • bzrudi

          bzrudi - 2008-01-10

          Hi bcsi,

          I'm pretty sure it' not a problem of PHP5, so there is no need to "downgrade". I noticed this issue with the environment var years ago and it might be not the same issue, but as far as I remember the issue is caused by a mis configured PERL installation. So please try to disable loading of mod_perl in http.conf (if enabled).
          It's just an idea but may be worth giving it a try IMHO.

          cheers bzrudi

          • bzrudi

            bzrudi - 2008-01-10


            I meant not a problem of PHP at all and therefore not only PHP5 specific ;-)

            cheers bzrudi

            • b.c.s.i.

              b.c.s.i. - 2008-01-14


              You nailed that one! Not sure what perl has to do with this problem but what they heck...

              I removed the mod-perl and LoadModule perl_module and then all of a sudden I could do a dir and other commands.

              But any commands like vi and anything that requires screen formatting and terminal input just doesn't work.

              I guess the program is limited to simple command line input and isn't really what I'm looking for.

              Thanks for your help though; I'm always happy to learn something new.



Log in to post a comment.