#4439 (ok 4.3) Table list in left panel doesn't expand

4.2.2
fixed
nobody
None
1
2014-12-05
2014-06-03
No

Click a database name on the left. The list of tables expands as normal. Click a table name and it stays open.

But if you do certain actions on a table, the left pane keeps closing. When you click the table name in the breadcrumb at the top of the main panel.

One definite action to get this bug is to open a table in a new tab, i.e. right click on the table name in the left panel and click "open in new tab". But it also happened a few times in general use, possibly when running update/insert queries from the query box.

Discussion

  • Marc Delisle

    Marc Delisle - 2014-06-08

    Clicking a table name in the navi panel is not supposed to make it expand; it's only supposed to accomplish the default action which is Browse for this table.

     
  • Madhura Jayaratne

    Reading the descriptions, I think the bug is about the left panel keeps closing.

     
  • Atul Pratap Singh

    I can't reproduce this on master by doing:-
    1. click table name from breadcrumb.
    2. open table in new tab from left pane.
    3. run update/insert queries.

     
  • Atul Pratap Singh

    • status: open --> pending
     
  • DisgruntledGoat

    DisgruntledGoat - 2014-06-11

    Clicking a table name in the navi panel is not supposed to make it expand; it's only supposed to accomplish the default action which is Browse for this table.

    Just to clarify, I am talking about the database section collapsing. I click on "mytable" but the whole tree below "mydatabase" collapses.

    One other trigger for the bug in 4.2.2 was removing the column ordering (with shift+click) that randomly appeared on some tables.

    But I think the issue is fixed now in 4.2.3. I've tried a few different things and the table list hasn't unexpectedly closed. Maybe it was a side-effect of the errors from https://sourceforge.net/p/phpmyadmin/bugs/4440/ since it occurred in similar circumstances.

     
  • Atul Pratap Singh

    • status: pending --> works-for-me
    • Priority: 5 --> 1
     
  • DisgruntledGoat

    DisgruntledGoat - 2014-07-05

    So it turns out this error is still occurring when importing data into a table. In other words, go to the Import tab of a table and import something, then the left pane keeps staying closed.

    Again, this could be related to #4440 or #4483.

     
  • DisgruntledGoat

    DisgruntledGoat - 2014-07-05

    Another situation where this occurs: adding an index to a table. Go to the Structure tab, select some fields then click one of the index buttons below the field list table.

    In both these cases the URL changes from index.php (or blank if I started at example.com/phpmyadmin/) to import.php or tbl_structure.php. That may be relevant.

    EDIT: next one.

    Follow above but go to Operations tab. In the Copy Table box, put a new table name, same database, Structure Only, and tick "Switch to new table". Click Go, and the table list in the left panel collapses again. Clicking the table name at the top of the page takes you back to the Browse view but the table list stays collapsed at the left.

    Also, the second time I did this, the + icon next to the database name changed to the loading spinner icon, and stayed like that, as if it was trying to load the table list. I think this was because the new table I created (by copying) meant the table list now spanned an extra 'page' (i.e. the table list previously had 2 pages, now it has 3).

     
    Last edit: DisgruntledGoat 2014-07-06
  • Atul Pratap Singh

    • status: works-for-me --> open
     
  • Marc Delisle

    Marc Delisle - 2014-07-28
    • summary: Table list in left panel doesn't expand --> Table list in left panel keeps closing
     
  • Isaac Bennetch

    Isaac Bennetch - 2014-07-28
    • summary: Table list in left panel keeps closing --> (ok 4.3) Table list in left panel doesn't expand
    • status: open --> resolved
     
  • Marc Delisle

    Marc Delisle - 2014-12-05
    • Status: resolved --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks