#4185 (ok 4.1.1) Unable to execute create procedure statement from query window

Latest_Git
fixed
None
1
2013-12-17
2013-12-15
Umair Khan
No

Steps to reproduce :
1. Open a table inside the database.
2. Click on the Edit link (next to Inline link), which is inside the box for showing executed query. This will pop up a query window.
3. Execute an statement to create a procedure.

A blank page is shown.

Discussion

  • Chanaka Indrajith Dharmarathna

    Umair,
    Your reproducing steps, bit confusing me. I could create a procedure using the SQL query window in latest phpMyAdmin version(4.2.0-dev). It will be helpful to give any code samples you tried, and clear steps to reproduce please.

     
  • Archit Verma

    Archit Verma - 2013-12-16

    It is possible to create a procedure if you click on 'SQL' in the navigation bar but when one clicks on the edit and executes the query it shows a blank page. I have submitted a pull request to fix this bug https://github.com/phpmyadmin/phpmyadmin/pull/791. Please check if it is correct or not.

     
  • Chanaka Indrajith Dharmarathna

    Archit,
    Thanks for working on this. By the way, I still couldn't reproduce this in the latest PMA. What are the steps did you followed to reproduce this ?

     
  • Archit Verma

    Archit Verma - 2013-12-16

    To reproduce the bug I followed these steps:
    1. Click on a table inside any database.
    2. In the browse tab just below the query(SELECT * FROM `tablename') click on '[Edit]'.
    3. In the query window that opens up execute any query.

    This results in a blank page.

     
  • Chanaka Indrajith Dharmarathna

    • summary: Unable to execute create procedure statement from querywindow --> Unable to execute create procedure statement from query window
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,6 +1,6 @@
     Steps to reproduce :
    -1. Open a table inside the databse.
    -2. Click on the edit link then the querywindow will open.
    +1. Open a table inside the database.
    +2. Click on the Edit link (next to Inline link), which is inside the box for showing executed query. This will pop up a query window.
     3. Execute an statement to create a procedure.
    
     A blank page is shown.
    
     
  • Marc Delisle

    Marc Delisle - 2013-12-16

    Archit,
    I cannot reproduce the problem you describe. Tested with 4.1.0, 4.1.1-dev and current master.

     
  • Archit Verma

    Archit Verma - 2013-12-16

    The problem occurs when someone opens a table inside a database and clicks on the '[Edit]' link (next to Inline link and below the query - 'SELECT * FROM 'tablename') and executes a query in the query window that pops out. It results in a blank page being displayed. This can be fixed by directing user to import.php instead of sql.php. I have submitted a pull request for the same.

    I tested it using 4.2.0-dev

     
  • Marc Delisle

    Marc Delisle - 2013-12-16

    Archit,
    that's what I'm trying to do. In the popup, I replace the table name to another table name of the same database, click on Go and the results appear correctly in the main window. I am testing with master set to commit d7d55b7c7c4695604d95458a2ffeffd81fd6c5a6.

     
  • Archit Verma

    Archit Verma - 2013-12-16

    Sorry I just realised the problem occurs only when when you create a procedure of that table and not just on any query.

     
  • Marc Delisle

    Marc Delisle - 2013-12-16
    • assigned_to: Marc Delisle
     
  • Marc Delisle

    Marc Delisle - 2013-12-16
    • summary: Unable to execute create procedure statement from query window --> (ok 4.1.1) Unable to execute create procedure statement from query window
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2013-12-17
    • Status: resolved --> fixed