#3896 Data export for tables with name in uppercase broken

3.5.8
wont-fix
bug (4)
1
2013-06-11
2013-04-29
No

Data export is broken for tables which contain uppercase letters in their names. Every time I try to export data from such tables, I get message:

-- Error reading data: (#1146 - Table 'exampledb.exampletable' doesn't exist)

You can get this message when you try to export data rows from table named ExampleTable. For some strange reason it inserts table name in lowercase in sql when it tries to retrieve given rows.

Discussion

  • Ann + J.M.

    Ann + J.M. - 2013-05-01

    Created table like this:

    CREATE TABLE IF NOT EXISTS `testTable` (
      `testField` int(1) NOT NULL
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1;
    
    --
    -- Daten für Tabelle `testTable`
    --
    
    INSERT INTO `testTable` (`testField`) VALUES
    (1);
    

    Exporting as text or file works fine.

    Please provide detailed steps to reproduce.
    Also: Are you able to reproduce the problem at http://demo.phpmyadmin.net/ ?

     
    Last edit: Ann + J.M. 2013-05-01
  • Ann + J.M.

    Ann + J.M. - 2013-05-01
    • status: open --> pending-works-for-me
    • assigned_to: J.M.
    • Priority: 5 --> 4
     
  • Sergejs Gribs

    Sergejs Gribs - 2013-05-01

    Yes, I missed one thing in problem description - it happens only when you are in Browse mode and select some rows to export. To reproduce:

    1) Choose table which has uppercase letter(s) in it's name, enter Browse mode directly (or through Search).
    2) Select some rows using checkboxes.
    3) Press export under data table (which exports selected rows only).
    4) Choose export parameters (make sure that you've chosen "data" or "structure and data" export), press Go.
    5) You get SQL error instead of data in your exported sql.

    And yes, I successfully reproduced this bug at http://demo.phpmyadmin.net/ .

     
  • Ann + J.M.

    Ann + J.M. - 2013-05-01
    • status: pending-works-for-me --> open
    • Priority: 4 --> 5
     
  • Ann + J.M.

    Ann + J.M. - 2013-05-03
    • status: open --> closed-wont-fix
    • Priority: 5 --> 1
     
  • Ann + J.M.

    Ann + J.M. - 2013-05-03

    Thanks for your detailed report.

    This bug appears in phpMyAdmin 3.5.8, but has been fixed for 4.0.x.

    Since phpMyAdmin 4.0.0 will be released soon, we won’t fix this bug for the 3.5.x series. After the release, consider upgrading, or hint your server administrator to do so for you. I suggest you to subscribe to the phpmyadmin-news mailing list, which will notify you instantly when phpMyAdmin 4.0.0 is available.

    Is this okay for you?

    Best, J.M.

     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-wont-fix --> wont-fix
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks