#3676 Continuous SQL statements causes repeated execution

2.11.9
works-for-me
nobody
AJAX (99)
5
2013-06-11
2012-09-06
Anonymous
No

When a number of SQL queries are issued one after the other in the SQL tab, nth query is run n number of times.

How to reproduce (my case):

1. Select a database
2. Type "CREATE TABLE `test_1` (`field_1` varchar(1) NOT NULL)" in the SQL textarea
3. Press 'Go' button
4. Edit the statement to change only the table name (test_1 to test_2)
5. Press 'Go' button
6. Press 'Go button again (do not edit the statement)
7. There will be 3 'table_2 already exists' error instead of just 1.

Also, giving more number of queries in the above manner causes some javascript to become non-responsive and hang the browser.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-09-06

    Screenshot

     
  • Marc Delisle

    Marc Delisle - 2012-12-02
    • status: open --> pending
     
  • Marc Delisle

    Marc Delisle - 2012-12-02

    Just by seeing the theme used, this looks like an old phpMyAdmin version. Cannot reproduce in 3.5.x.

     
  • Marc Delisle

    Marc Delisle - 2013-01-18
    • status: pending --> closed-works-for-me
    • milestone: --> 2.11.9
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-works-for-me --> works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks