SMTP settings failing when I attempt to send a test email. I get the following message.
SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)
SMTP connect() failed.
Mailer Error: SMTP connect() failed.
Have confirmed from the server that I am able to telnet to port 25 with both the DNS and IP address of my SMTP server and send HELO. There is no authentication required on the SMTP server. I did a packet capture while attempting a test email and did not see any DNS requests for the SMTP server, nor any connection attempts to its IP address on any port. I've attached a copy of my phpinfo page, and I am running an up to date fresh install of Debian 7.
Anonymous
You entered hostname or IP for server? If hostname, can you try with IP address?
I entered both IP and DNS
Still awaiting further info
Hi, can you add a
line to beginning of site/admin/mailSettingsTestMail.php and send optput (you can change IPs etc)?
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
That's the output.
Array ( [mtype] => smtp [mserver] => X.X.X.X [mport] => 25 [msecure] => none [mauth] => no [muser] => [mpass] => [mAdminName] => Administrateur IPAM [mAdminMail] => frank@mydomain.com ) SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)
SMTP connect() failed.
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
Proposed patch #22 fixed it.
http://sourceforge.net/p/phpipam/patches/22/
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
$mailsettings = $settings;
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
Hi,
I have a different issue, I have applied the patch but when I'm testing I got this:
Array ( [mtype] => smtp [mserver] => 172.16.3.200 [mport] => 25 [msecure] => none [mauth] => no [muser] => admin [mpass] => phpipamadmin [mAdminName] => exameple@example.com [mAdminMail] => example@example.com ) Connection: opening
SMTP ERROR: Failed to connect to server: Permission denied (13)
SMTP connect() failed.
I don´t know why the setting is getting my admin user, my config is empty for user and password, I'm not using authentication
pd: example.com it's an example :)
Regards.
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
Array ( [mtype] => smtp [mserver] => 172.16.3.200 [mport] => 25 [msecure] => none [mauth] => no [muser] => admin [mpass] => phpipamadmin [mAdminName] => ELS_IP_Admins@digicelgroup.com [mAdminMail] => ELS_IP_Admins@digicelgroup.com ) Connection: opening
SMTP ERROR: Failed to connect to server: Permission denied (13)
SMTP connect() failed.
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
Array ( [mtype] => smtp [mserver] => 192.168.7.3 [mport] => 25 [msecure] => none [mauth] => yes [muser] => xxxxx@mygrille.de [mpass] => xxxx [mAdminName] => xxxx@mygrille.de [mAdminMail] => xxx@csre.de ) SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)
SMTP connect() failed.
I'm having this problem now. Can anyone else confirm?
Edit: I'm an idiot and can't search.. https://sourceforge.net/p/phpipam/patches/22/
Last edit: John Doe 2015-08-11
View and moderate all "support-requests Discussion" comments posted by this user
Mark all as spam, and block user from posting to "Support Requests"
me