phpFormGenerator v3.0 demo site

Help
2007-06-14
2013-06-03
1 2 3 .. 18 > >> (Page 1 of 18)
  • Musawir Ali

    Musawir Ali - 2007-06-14

    Dear users,

    I'm proud to announce that v3.0 has passed the development stage and is ready to be tested out. Before I actually release it on SourceForge for public download, I have setup a demo site where users can test drive the program. Users will be able to generate and "DOWNLOAD" forms directly from the demo website. This allows users to check the program out before installing it themselves. The demo site is located at: http://www.phpformgen.com

    Also be sure to check out the tutorial video: http://phpformgen.sourceforge.net/video/phpformgen.html

    During the testing phase, if you encounter any bugs please report them on the "Help Forums".

    Thanks!

     
    • ayoughi

      ayoughi - 2007-06-17

      Hi
      I use MySQl DB for delivery form information. but after install this Error was showed:

      "
      Table created.
      Warning: fopen(config.inc.php) [function.fopen]: failed to open stream: Permission denied in C:\Inetpub\vhosts\islamic-finance.ir\httpdocs\registration\install.php on line 220

      Warning: fwrite(): supplied argument is not a valid stream resource in C:\Inetpub\vhosts\islamic-finance.ir\httpdocs\registration\install.php on line 230
      Cannot write to file.
      "

      please help me...

       
      • Najaf

        Najaf - 2007-06-17

        Hello ayoughi and thank you for testing out the beta version.  The install.php program creates a file with your database parameters.  It writes to a 'config.inc.php' file within the same directory.  I suspect that since you're using it on windows, it is trying to write to a directory that it does not have permissions for. 

        You can try creating a config.inc.php file within your form directory and running the install.php once again, and see if it runs.  Try giving full permissions to config.inc.php file and see if that makes a difference.  Remember to change the permissions back for security purposes.

        It is possible that it's reading from the wrong directory altogether.  If this is the case, you can try changing the stuff on line 220 from $handle = fopen('config.inc.php', 'w'); to $handle = fopen('C:\\Inetpub\\vhosts\\islamic-finance.ir\\httpdocs\\registration\\config.inc.php', 'w');

        Hope this works for you...please let us know so we can be sure that there aren't any issues on Windows.

         
        • Anonymous - 2007-11-05

          I have almost the same problem although I created a file called config.inc.php and change it's
          permissions to 777 and made writable no chance and I get the same error

          Is there anyone kindly past the config.inc.php file structure so I can configure is
          manually by myself. therefore nothing works and without this file i can not write or store
          the data in database.

          Warning: fopen(config.inc.php) [function.fopen]: failed to open stream: Permission denied in c:\Inetpub\wwwroot\testingserv\registermyinterest\install.php on line 231

          Warning: fwrite(): supplied argument is not a valid stream resource in c:\Inetpub\wwwroot\testingserv\registermyinterest\install.php on line 241
          Cannot write to file.

           
          • TNTEverett

            TNTEverett - 2007-11-05

            Each install.php file is different.  Without seeing your file there is no way for me to tell what the error means. 

             
    • ayoughi

      ayoughi - 2007-06-17

      hi
      thank for answer about my previous question. i change folder permission and everything became ok. but i have 2 other questions:
      1. i can not recieve my data in persian language (with SQL). i have changed collection to utf8_persian_ci but data weren't recieved correctly yet. help please...

      2. i added file field to my form for recieving file from visitors. but i cann't recieve anyfile (with SQL). (in related table show 0 Kb). i need help...

      thanks alot

       
      • ayoughi

        ayoughi - 2007-06-18

        hi again
        i found answer of question 1, i must add N begin of 'filed_...'. for example:
        INSERT into `".$db_table."` (field_1) VALUES ('" . $_POST[N'field_1'] . "')";
        but i have uestion no. 1 yet. please help

         
        • Najaf

          Najaf - 2007-06-18

          Hi ayoughi.  I don't have experience with SQL/PHP in other languages so my suggestions may not work for you.

          However, it seems like there can be several possibilities:

          1) make sure your database is set to utf-8  and your tables are utf8-persian-ci.
          2) edit your php.ini file and look for mbstring.  Seems like the following parameters should be set:

          mbstring.internal_encoding  = UTF-8
          mbstring.http_input = UTF-8
          mbstring.http_output = UTF-8

          3) on Windows, you may also have to enable the extension=php_mbstring.dll line and copy the necessary dll file over.

          Please keep us posted on how this works out for you.

           
    • ayoughi

      ayoughi - 2007-06-19

      Hi najaf
      I added N in begin of 'field_..' in prossesor.php and now i can see correct font in my database.

      can you tell me how can i see uploaded file in my database (now uploaded file is sent to files directory in my host)?
      thanks

       
      • Najaf

        Najaf - 2007-06-20

        Hi ayoughi, glad it worked for you.  I'll have to try it out myself and see if this is something that should be standard.

        Right now, we do not offer file storage in databases simply because it will introduce a new set of issues.  However, we'll put that on our list of requested features.

         
    • TNTEverett

      TNTEverett - 2007-06-19

      Is this the only thread you wish to have errors/bugs reported to?

       
    • TNTEverett

      TNTEverett - 2007-06-19

      Created one form.
      1.) Where is the admin feature?  How do I review data submitted through my form?
      2.) Files uploaded have completely lost the original file name.  The old version put a time code in front of the file name.  Why has this been changed?
      3.) Files uploaded no longer have an extension.  Files uploaded with either .shtml or .html loose the ".s" or "." respectively.
      4.) I first tested my form with Uniformserver (local PC web server suite) and the Captcha feature worked fine.  When uploaded to my site the Captcha feature stopped working.  Any idea why this might happen? 
      5.) While creating my form I added file upload entries.  The "required" and "not required" buttons where visible but not usable.  Why are these buttons displayed if they can not be used or a better question, why can they not be used? 

       
      • houstondill

        houstondill - 2007-06-19

        Question #1 and #5 apply to me as well. Also I can browse the database but any data captures by means a Check box is lost and "Array" is in its place. Thanks.

         
      • Najaf

        Najaf - 2007-06-20

        > Where is the admin feature? How do I review data submitted through my form?

        Email option sends you an email with the info submitted.  File option appends info to a file.   Database entries right now have to be viewed from whatever application you can interface with MySQL.

        > Files uploaded have completely lost the original file name. The old version put a time code in front of the file name. Why has this been changed?

        This is done to avoid collisions.  However we'll think about putting some identifying info.

        > I first tested my form with Uniformserver (local PC web server suite) and the Captcha feature worked fine. When uploaded to my site the Captcha feature stopped working. Any idea why this might happen? 

        I don't know the particulars of your local site so I cannot know what the problem is.  I would check and make sure you have sessions enabled.

        > While creating my form I added file upload entries. The "required" and "not required" buttons where visible but not usable. Why are these buttons displayed if they can not be used or a better question, why can they not be used? 

        Seems like that is a browser issue.  Use firefox if you need to use that feature for now.

         
        • TNTEverett

          TNTEverett - 2007-06-25

          Seems like we've taken quite a few steps backwards as far as features and capabilities.  Is there a list of features/capabilities lost or on a waiting list for reintroduction? 

           
    • Michael Erb

      Michael Erb - 2007-06-23

      I changed the order of a few fields using the up and down arrows. After saving the form and downloading the zip and installing it on my server, the resulting emailed result of the submission was all out of order with mismatched fields and values.

       
    • phill104

      phill104 - 2007-06-23

      Excellent piece of work. It worked a treat for me as you can see here

      http://www.windsurf.me.uk/Links/links2.html

      One feature that I would have found very usefull would be the facility to add a numerical field with a user set range of numbers.

      For instance, in my form the user has to enter a longitude and latitude in decimal format eg. 52.347553. Most users were ignoring the instructions and entering it in other formats such as N 52:23,44. This caused the map to die.

      If a numerical field could have been added I could have set the range from -90 to 90 then if data was entered outside those values outside those values the validatefield bit could reject it.

      I have coded that into the form myself (though not uploaded it yet as still testing) but others might find it usefull for such a feature.

       
    • protfinder

      protfinder - 2007-06-24

      Simply an exelent aplication.

      A little bug: I get the <ul class=mainForm id="mainForm_1"> closing tag after the end of the form when it should be just before.

      Excellent tool!!

       
    • ezpz

      ezpz - 2007-06-24

      Does  phpFormGenerator operate with register globals turned off???

       
    • decadora

      decadora - 2007-06-25

      I cannot seem to get this form to work. Am I missing to do something in the php file? My hosting server does have PHP enabled. Can someone help?

      Thanks

      <?php

      $where_form_is="http://".$_SERVER['SERVER_NAME'].strrev(strstr(strrev($_SERVER['PHP_SELF']),"/"));

      mail("rabih@decadora.com","phpFormGenerator - Form submission","Form data:

      Company Name:: " . $_POST['field_1'] . "
      Loan Agent Name:: " . $_POST['field_2'] . "
      Loan Agent Phone:: " . $_POST['field_3'] . "
      Loan Agent eMail:: " . $_POST['field_4'] . "
      Reference Number:: " . $_POST['field_5'] . "
      Requested Signing Date:: " . $_POST['field_6'] . "
      Requested Signing Time:: " . $_POST['field_7'] . "
      Full Name of Each Person Signing:: " . $_POST['field_8'] . "
      Location of Signing:: " . $_POST['field_9'] . "
      Address:: " . $_POST['field_10'] . "
      City:: " . $_POST['field_11'] . "
      State:: " . $_POST['field_12'] . "
      Zip:: " . $_POST['field_13'] . "
      Is this address same as the property address:: " . $_POST['field_14'] . "
      City:: " . $_POST['field_15'] . "
      State:: " . $_POST['field_16'] . "
      Zip:: " . $_POST['field_17'] . "
      Borrower Home Phone:: " . $_POST['field_18'] . "
      Borrower Work Phone1:: " . $_POST['field_19'] . "
      Borrower Work Phone2:: " . $_POST['field_20'] . "
      Document Type:: " . $_POST['field_21'] . "
      Documents Type:: " . $_POST['field_22'] . "
      Date Documents will be sent:: " . $_POST['field_23'] . "
      Documents will be sent by:: " . $_POST['field_24'] . "
      If Other please specify:: " . $_POST['field_25'] . "
      Additional Instructions:: " . $_POST['field_26'] . "

      powered by phpFormGenerator.
      ");

      include("confirm.html");

      ?>

       
      • TNTEverett

        TNTEverett - 2007-06-25

        Without PHP installed and enabled this will never work.  Ask your host to setup PHP.  It's free and it's easy. 

         
    • thomas

      thomas - 2007-06-25

      HELP!!!  I Created a form and posted it to a site, but it doesn't send the info via email like it's supposed to. did I do something wrong?

      Thanks!

       
      • Pepepp

        Pepepp - 2008-04-12

        PhpFormGenerator v2.09 is available from my hosting. I installed it and it
        makes good forms. However, the problem is that no info goes to Email where
        I want to get that info. No error messages, everything seems just to disappear!
        The hosting server has PHP4 or PHP5 enabled. I suspect that process.php does
        not work but unfortunately I am not very familiar with php and cannot fix
        this kind of problem. Some other people in this forum have had similar
        problems but I cannot see any advice how they were solved. I would be grateful
        for any help!

         
        • TNTEverett

          TNTEverett - 2008-04-13

          Have you checked with your host to see if the php mail function should work?
          In version 2.09 sometimes this line causes problems:
          $where_form_is="http".($HTTP_SERVER_VARS["HTTPS"]=="on"?"s":"")."://".$SERVER_NAME.strrev(strstr(strrev($PHP_SELF),"/"));

          You can try removing it but be prepared to put it back if any other feature no longer works.

           
          • Pepepp

            Pepepp - 2008-04-14

            Thanks for your reply. However, I found out that the mailing is working if
            the Email address is in the same server as the form, otherwise no reception
            of the form content sent to other Email addresses. This solution is alright
            for my use. I shall test whether there would be other possibilities too.

             
1 2 3 .. 18 > >> (Page 1 of 18)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks