RTP header missing? Frame composition.

Help
FOH
2007-12-07
2013-04-25
  • FOH

    FOH - 2007-12-07

    Hello All,

    I have installed packETH on my Debian system. It compiled with no problems.
    At the moment I am trying to generate some RTP traffic for which this tool would be ideal.

    The problem I am having is that when I construct a UDP packet (Builder screen) and then proceed to 'Select Payload' button to specify the RTP parameters ( payload type, timestamp, sequence number, etc.) the resulting frame does not contain the RTP portion at all.
    It is constructed as [eth:ip:udp:data] instead of [eth:ip:udp:rtp]  

    Since there is no RTP header in the frame the packet is recognized as UDP data packet and not as an RTP. Other relevant information such as payload type, timestamp, sequence # which was specified during construction of the packet is missing as well.

    Am I missing something obvious?  I'll appreciate any insights for this matter.
    Thank you.
    I.P.

     
    • Miha Jemec

      Miha Jemec - 2007-12-13

      How do you know the RTP header is missing? UDP header doesn't contain any information about higher layer protocol, if you don't have the signaling information, wireshark f.e. won't be able to decode this packet as RTP since the ports are assigned arbitrary.

      I checked and 1.4.1 works well.

      Create an UDP packet, go inside the Select payload, choose a frequency, let's say 1000 and length 80, press apply into payload and check the include UDP payload checkbox. Then send this packet out on a lo interface and capture it at the same time with wireshark. Select the packet, right click and choose Decode as, select RTP and you should see the RTP header present.

      Regards, Miha

       
      • FOH

        FOH - 2007-12-14

        Miha, thank you for your reply. The issue is resolved. Indeed it was a decoding method I've used.

        Thanks again. Great tool.

        Igor.

         
    • Mihir Mehta

      Mihir Mehta - 2009-01-23

      Hi Miha,

      I was trying to do the same.It worked for me once. But now again when I try, under the Decode As in wireshark for a particular RTP packet, I dont see the option of choosing the transport layer protocol. It shows only link and network layer protocol options. The help in Wireshark suggests that you will be able to see the appropriate packet only if it existed. Following the steps you mentioned above, it does not show me the transport layer option at all. Can you help me here?I am using the latest Wireshark version.

      Thanks in advance,
      Mihir

       
    • Miha Jemec

      Miha Jemec - 2009-01-23

      Hi MIhir,

      if the packet you sent out on the link is UDP, then you should see the option to choose RTP in the Decode As dialog box. I can't see any other reason for this.

      Miha

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks