#92 Failures in parallels virtualized environment

open
nobody
General (51)
5
2014-02-10
2008-07-10
No

Vine 3 refuses to run while installed on MacOS Server 10.5.4 Leopard running in Parallels Server 3.0 for Mac.

The actual problem is what if the parallels video drivers are used, the functions following functions are returning 0 instead of valid values:
CGDisplaySamplesPerPixel(displayID)
CGDisplayBitsPerSample(displayID)

This results in "screen format not supported" complains and Vine server refuses to start.

The attached hack fixes problem for me just by using default values if 'CGDisplayBitsPerSample' returns 0.

Discussion

  • wonder_mice

    wonder_mice - 2009-01-14

    Hello,
    We have fixed this. Patch will be available in our next update (but not in hotfix). Please check this when it will be out. With other Parallels related problems you can mail to our free support with note to redirect it to andreyp@

     
  • Luke Stanley

    Luke Stanley - 2011-07-02

    The last binary download on this site is from 2007, the last comment on this is 2009.
    Explains why I'm getting this bug still?
    Is http://www.testplant.com/products/vine/ related? The link for more info redirects to itself. I'm working on a bootstrapping vncserver download and execution script for easy debugging on end users computers or whatever else!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks