#81 v2.5 Beta - Validation vs Translation

pending-postponed
nobody
Validity (4)
9
2011-07-18
2011-04-10
No

There are instances when the document validates using the "Validate" button on the Accessibility ribbon but during the process of conversion to DTB XML, validation errors appear. The validation rules are not consistent.

Discussion

  • Prashant Ranjan Verma

    This file Validates but DTB XML translation fails. Validation errors are detected in list tags.

     
  • Prashant Ranjan Verma

    • labels: --> Validity
    • priority: 5 --> 9
     
  • Prashant Ranjan Verma

    Expected behaviour: If the document validates then translation should not fail due to document validation errors. The validation tests done by the DAISY Pipeline should be integrated into the DAISY Translator Validator.

     
  • Prashant Ranjan Verma

    • status: open --> pending
     
  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     
  • Prashant Ranjan Verma

    • status: closed --> pending
     
  • chrisauld

    chrisauld - 2011-07-18
    • status: pending --> pending-postponed
     
  • chrisauld

    chrisauld - 2011-07-18

    My understanding is that Romain was going to provide a mechanism for us to have the pipeline perform all of the validation and return an error set to us. This is to avoid du-plicating the work to write the validation code.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks