i am getting similar error and i just wonder that is it fixed? I am using following combination,

Server:
Centos 6.4 (Final) X86_64 and following freenx and nx packages were installed.
freenx-0.7.3-9.4.el6.centos.x86_64
nx-3.5.0-2.1.el6.centos.x86_64

Client:
Mac OS 10.9
OpenNX (0.16.0.729) installed.

Regards,

--ufuk