#12 Wrong window size for the macro

open
nobody
Interface (10)
5
2008-05-12
2008-05-12
PolR
No

Sometimes the macro window show up with the wrong size, hiding data and buttons and making it unusable. See screenshots for examples of the problem. The problem occurs with all three of the equation, expand and config windows on an empty text file in writer as well as on an empty presentation in Impress.

The screenshots are for writer only, but it happens in Impress as well.

This problem occurs on Ubuntu 8.04 with OOo 2.4 with a System 76 pangolin laptop. I have a desktop using the same versions of Ubuntu and OOo that does not exhibit the problem.

The problem is also erratic. Sometimes the window may display right for no apparent reason, but this does not happen often.

Discussion

  • PolR

    PolR - 2008-05-12

    Screenshots showing the problem in writer

     
  • Léo Studer

    Léo Studer - 2008-05-22

    Logged In: YES
    user_id=1612334
    Originator: NO

    I confirm this bug, using Ubuntu 8.04 with OOo 2.4 on a quad core desktop. The same desktop has a Ubuntu 7.10 partition with OOo 2.3 that doe not have this issue.

    Using openjdk on Ubuntu 8.04.

    And I can confirm that this behaviour is mostly erratic, changing page or zoom might be able to fix it for a while, then it will pop up again.

     
  • Léo Studer

    Léo Studer - 2008-05-22

    Logged In: YES
    user_id=1612334
    Originator: NO

    I really don't know much about OOo scripting, but however I gave a try to tweaking the OOoLatexEquation_GUI.xdl file adding dlg:resizeable="true" in the dlg:window declaration

    However this has no impact on the behaviour of the window.

    Any small hint would be greatly appreciated to make this extension work again with OOo 2.4 on Ubuntu!

     
  • Léo Studer

    Léo Studer - 2008-05-22

    Logged In: YES
    user_id=1612334
    Originator: NO

    It appears that this behaviour is not happening with OOo 2.4 on Windows XP

     
  • Eruantalon

    Eruantalon - 2008-06-06

    Logged In: YES
    user_id=1155715
    Originator: NO

    Same problem, also empty document, Ubunu 8.04, OOo 2.4, but with a Zepto 6615WD laptop

     
  • Nobody/Anonymous

    Logged In: NO

    Same here, Ubuntu 8.04 OpenOffice 2.4.1

    A fix would be nice, or at least the windows should be resizable

     
  • Nobody/Anonymous

    I'm confirming this issue.

    The same workaround can be achieved via terminal. Run terminal and type:

    metacity --replace

    Install missing dictionaries in OO and then go back to terminal (if the metacity --replace is still running, then press ctrl+c to stop it) and type:

    compiz --replace

     

Log in to post a comment.