Error: NppToR was able to find Notepad++, ..

  • mbtrash

    mbtrash - 2012-10-22

    I use NPP vers. 6.2 and NPPtoR vers.2.6.2. The installation runs fine. But if I try to start an R-command from NPP than I get the following error:
    Error(601): NppToR was able to find Notepad++ but for an unknown reason was unable to retrieve text.
    On my notebook with the same combination of versions and also Win7-64b it runs without problems.
    Thank you for soon help!

  • Andrew Redd

    Andrew Redd - 2012-10-22

    Is it always a problem or is it an occasional problem?

  • Frank

    Frank - 2012-12-12

    I also have this problem, but with a quirk. I have npp running in two windows. Tabs in the window on the left get the error, while tabs in the window on the right go through fine. When I move a tab to the other window, its commands go through. Closing R and npptor don't make the problem go away; and I don't want to close npp at the moment…

    I'm using

    NppToR 2.6.2 (portable)
    Npp 5.9.8 (portable; is it always?)
    R 2.15.1

    on a remote computer.

  • Frank

    Frank - 2012-12-12

    It turns out that the first window (when Npp opens) is the one for which it fails, while commands from the second (which I create by dragging a tab outside the first) work.

    (Sorry: I don't know how to edit my previous post.)

  • Andrew Redd

    Andrew Redd - 2012-12-13

    frank,  Great bug report.  I'm trying to replicate but unable to.  Explain the remote computer part please.  All three are running on the remote computer?  is this through a remote desktop?  Please elaborate on your situation.  It might have something to do with the remote aspect part of this.

  • Frank

    Frank - 2012-12-17

    Yeah, I can't replicate it on my (local) computer either (though I haven't tried down-grading to 2.15.1). I am accessing a Windows 7 system through Citrix Receiver, and all three (Npp, NppToR, R) are running on that system.

    I wouldn't be surprised if it had something to do with the remote access. Sometimes R on the remote system just ignores my F8 of highlighted text, too (so I have to do it multiple times or get impatient and copy-paste).

    Anyway, it's not a real problem for me now, as I can just make a new window and close the first. Thanks.

  • mbtrash

    mbtrash - 2013-01-04

    hi haplo

    Sorry you got no answer from me. (Wrong setting - hence I supposed you never answered… Please accept my apologies!)

    But my problem persists. And the problem occurs always. But only on one PC. I have two other installations with no problems and similar installations, which work fine:

    win 7 x64 (SP1)
    NPP 6.2.2
    NPPtoR 2.6.2.


  • Celes

    Celes - 2013-03-15

    hi haplo

    I have encountered this situation:

    first, I use
    WIN 8 x64
    NPP 6.3
    NPPtoR 2.6.2

    When I open the software teamviewer, I would get the following error:
    Error(601): NppToR was able to find Notepad++ but for an unknown reason was unable to retrieve text.

    but I closed it, and it worked well.

    I hope that this information is helpful for solving this bug.


    • S. Pruett

      S. Pruett - 2013-08-22

      Could I get a little help with this same issue. I just had my IT guy upgrade my software for R, Npp, and NppToR.

      Npp V6.4.3
      R V3.0.1
      NppToR V2.6.2

      When I tried to run code using the 8, I get the same error. Can you explain the "software teamviewer" you mention? I'm not sure exactly what I'm looking for.

      Thanks in advance!

      • Andrew Redd

        Andrew Redd - 2013-08-23

        Certain programs, such as teamviewer, have the ability to interfere with interprocess communication. These are most commonly security applications, of which teamviewer could be considered one. Also antivirus programs have been known to interfere with NppToR. I am sorry if there is another application interfering there is little that can be done but stop the program or service. If I find a better way to facilitate the communication I certainly will implement it.

  • mbtrash

    mbtrash - 2013-05-25

    Hi haplo, hi Celes


    Wow, what surprise! It was also in my case the TeamViewer causing the error! As soon I kill the process and stop the service of TeamViewer, NppToR runs fine. I have currently the following configuration:

    win 7 x64 (SP1)
    NppToR 2.6.2
    Notepad++ 6.3.2
    R 2.15.2 (64-bit)

    Thanks a lot to Celes for this crucial hint!!!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks