Line Spacing

2005-07-22
2012-11-13
  • Nobody/Anonymous

    Unfortunately I could not find a possibility to change the line spacing

     
    • Nobody/Anonymous

      When you first atart notepad++ all the spacing is messed up (really large spacing between the lines).

      I fixed it by opening the stylers.xml file and making fontname="" and fontsize="" except at the 1st line of <GlobalStyles> there I assigned the font and size I wanted to use. hope this helps

       
      • Nobody/Anonymous

        I tried the suggestion here and for some reason the lines all have extended height above the font size. It is especially noticable when viewing .nfo files. Or any text file using ascii art. I even tried renaming the stylers.xml and got a 'can't read stylers.xml' error (as expected) but it still opened the text file and still had extended height above the font it loaded. Aside from the stylers.xml is it set somewhere else what default font and size to use?

         
        • Nobody/Anonymous

          yeah i have also reduced the font size of global styles' brace highlight style to 10, but there is still a huge discrepancy when viewing an nfo file in notepad++ compared with notepad using Terminal font.  for now i have make an exception to open .nfo files with original notepad until this line spacing is corrected.

           
    • Nobody/Anonymous

      Thanks for your answer, but I think, you have not understand my problem: I would not change the fontname and the fontsize, but the space between the lines, which is now as standard double space.
      Can you please give me a tip?

       
    • Nobody/Anonymous

      Hello,

      I also was looking for answer to this and tried the suggestion of modifying the fontsize. It does fix the issue. I'm not sure why, but it appears as though the "line spacing" depends on the size of the largest fontsize. If all the fonts are the same size then the spacing will change accordingly, at least it did for me. I had one font as 12 and the rest 10. Once I changed that 12 to 10 it was fixed.

      Hope this helps.

      -- Richard

       
      • Nobody/Anonymous

        The problem is because of the "Brace highlight style" Style of the "Global Styles" language.
        It has a default size 12.
        Remove the Font size from this, and you will be OK!

        (This is really an annoying problem; font size should be removed from here at the default settings.)

         
        • Nobody/Anonymous

          This was the solution that worked for me.  Thanks.

           
        • Nick Richards

          Nick Richards - 2006-05-09

          You are too awesome, M. Nobody.

          I am almost encouraged to fire up cvs and hack up support for this...I am not so intrepid though.

          Either: squeeze down the brace indent font size if display font smaller

          Or: display a little note in RED that the main font is smaller than the Brace font where he currently displays the Attention sign, and mention the fact that the line spacing is calculated based upon the largest font.

          ALSO: It'd be nice if we weren't limited to the drop down.  I would like to be able to enter "6" point fonts, but for some reason the drop down doesn't allow me to type in numbers, it's a straight forward drop down, not a text entry type...so I'm limited to 8, and thus I have to hack the XML to get the size I want.  6.

           
    • Gordon Yuen

      Gordon Yuen - 2005-08-22

      It seems we cannot use regular expression to search for CR, LF etc. characters, not to say to replace them. So how can I convert DOS text to UNIX?

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks