Haskell default for *.as files

SubOne
2008-05-30
2012-11-13
  • SubOne

    SubOne - 2008-05-30

    Is there any way to change *.as files to always use ActionScript language? The file extension is set for both Haskell and ActionScript and it is quite an annoyance to have to manually set it to ActionScript everytime I open an ActionScript file, as it defaults to Haskell language. I tried disabling the Haskell language in settings, but it just opens *.as files with (Haskell formatting still?) no language selected.

     
    • Stepan

      Stepan - 2008-06-03

      All you need is modify langs.xml in Notepad++ installation directory - something like "c:\Program Files\Notepad++\langs.xml".

      In langs.xml change line:
      <Language name="haskell" ext="hs lhs as las"  commentLine="--">
      to:
      <Language name="haskell" ext="hs lhs las"  commentLine="--">

      Then (re)start notepad++, auto files opened files remember language so close and open them manually to re-set language.

       
      • SubOne

        SubOne - 2008-06-04

        That's what I had to do. I wound up trying to change what elements are styled with which style in ActionScript. While I was there I made that change before I read your post, but thank you that's just the answer I would have needed :D

         
    • Fool4UAnyway

      Fool4UAnyway - 2008-05-30

      Perhaps you can find something useful in the thread called "File Association settings are not saved" started by jfnieto on 2008-05-28 12:54.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks