zebul666 - 2012-03-23

hello,

I am using a netgear WG311v3 with ndiswrapper.
I tried to make a bonding of eth0 (ethernet card) and wlan0 (the wifi
card) on archlinux 32 bits
This fails the moment I run manually

ifenslave bond0 wlan0

ifenslave seems to lock up/block
every attempt to run ifconfig after that fails (it just blocks and never
return the shell prompt) and the network is lost

What I see in /var/log/messages.log as significant is:

Mar 22 15:40:33 soho kernel: [ 2585.920343] ndiswrapper (mp_set_power_state:366): wlan0 does not support power management; halting the device

And the device is so halted that it screwed up every thing

I guess it's the same problem or at least it is related
I can't suspend to ram when using ndiswrapper with this card. The suspend
begins as normal the hdd even shutdown but the PC tower is still powered up.

I have not talked about the driver I used
I have tried the official netgear windows XP driver, version 3.1
And also a marvel driver (called netmw125) version 3.2.3.2. I don't know where
I was able to find it. It performs better than the netgear one (if you want to
have a look at it http://dl.dropbox.com/u/20635927/marvel_3.2.3.2.tar.gz)

So is it a bug in ndiswrapper ? is it related to the driver(s) ? is there
anything to do about it ? especially for the suspend to ram thing to be fixed
?