Andy Dustman - 2010-04-22

You may be able to skip a few substeps with 1.2.3c1 or newer. Editing site.cfg
can't really be helped, but we'll probably make 5.1 the default before 1.2.3.

The main thrust of this though is that you need to preinstall:

a) MySQL (installer)

b) MySQL (source)

c) Visual Studio (for build tools)