Cannot use MySQL-python on mac Mountain Lion 10.8

  • aliomattux

    aliomattux - 2013-01-25


    I have a mac pro with Mountain Lion 10.8. I am unable to use this python module. When it is installed, I get an architecture error. There are already many posts on this subject. Typically the message is that I have 32 bit mysql installed. I have tried BOTH 32/64 bit versions of mysql. Downloaded same day as post. Uninstalled, reinstalled and same with MySQL-python. Same result every time. I cannot get this module to work at all, and its really unfortunate because I wanted to use sqlalchemy, which seems to depend on this module functioning to create a mysql engine.

    I have seen many many posts on this same error, but I tried everything for HOURS and cannot at all get this module to work. It works great on a linux machine, but not my expensive mac pro. Extremely frustrating. I have brew, pip, easy_install installed. all 3 do not yield a successful result.
    Any suggestions?

  • Andy Dustman

    Andy Dustman - 2013-01-25

    Is it possible that you have more than one version of MySQL installed, or that you got one of the "fat binary" packages from If even brew is failing, one of these two things seems very likely.

    Could you at least post the last few lines before the error occurs? And if there is a _mysql.o file created, the output from "file _mysql.o". Also, include the output of the mysql_config command and make sure the build is using the same path to get to it.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks