mpd5: Cannot get tee node id: No error: 0 ???

Aleksandr
2013-03-22
2013-03-28
  • Aleksandr

    Aleksandr - 2013-03-22

    Hi!
    I have troubles with mpd, sometimes it works many days without problems, but some day it stop working with that error:

    Cannot get tee node id: No error: 0
    

    full log output is:

    Mar 17 10:19:20 srv mpd: [L-PPTP] LCP: SendTerminateReq #4
    Mar 17 10:19:22 srv mpd: [L-PPTP] LCP: state change Stopping --> Stopped
    Mar 17 10:19:22 srv mpd: [L-PPTP] LCP: LayerFinish
    Mar 17 10:19:39 srv mpd: [L-PPTP] PPTP call terminated
    Mar 17 10:19:39 srv mpd: [L-PPTP] Link: DOWN event
    Mar 17 10:19:39 srv mpd: [L-PPTP] LCP: Down event
    Mar 17 10:19:39 srv mpd: [L-PPTP] LCP: state change Stopped --> Starting
    Mar 17 10:19:39 srv mpd: [L-PPTP] LCP: LayerStart
    Mar 17 10:19:39 srv mpd: [L-PPTP] Cannot get tee node id: No error: 0
    Mar 17 10:19:39 srv mpd: [L-PPTP] Link: reconnection attempt 1 in 7 seconds
    Mar 17 10:19:46 srv mpd: [L-PPTP] Link: reconnection attempt 1
    Mar 17 10:19:46 srv mpd: [L-PPTP] PPTP call successful
    Mar 17 10:19:46 srv mpd: [L-PPTP] PPTP: can't attach pptpgre node: No such file or directory
    Mar 17 10:19:46 srv mpd: [L-PPTP] PPTP call failed
    Mar 17 10:19:46 srv mpd: [L-PPTP] Link: DOWN event
    Mar 17 10:19:46 srv mpd: [L-PPTP] LCP: Down event
    

    this trouble solves only after restarting mpd.

    This server serve only two (2) mpd links.

    pptp config is:

    pptp1:
            create bundle static B-PPTP
            #set iface route a.b.c.d
            set iface route 216.239.47.126
            set iface route 8.8.4.4
            set iface route default
            set iface enable tcpmssfix
            set iface enable nat
            set nat red-port udp 0.0.0.0 20402 192.168.1.20 20402
            set nat red-port tcp 0.0.0.0 20402 192.168.1.20 20402
            set iface up-script /usr/local/etc/mpd5/1_up.sh
            set iface down-script /usr/local/etc/mpd5/1_down.sh
            set ipcp ranges 0.0.0.0/0 0.0.0.0/0
            create link static L-PPTP pptp
            set link action bundle B-PPTP
            set auth authname xxxxxx
            set auth password xxxxx
            set link eap yes md5
            set link max-redial 0
            set link mtu 1400
            set link keep-alive 10 20
            set link disable multilink
            set link redial-delay 5
            set pptp peer xxxxxxx
            set pptp disable windowing
            open
    

    FreeBSD version:

    9.1-STABLE FreeBSD 9.1-STABLE #1 r247004
    
     
  • Dmitry S. Luhtionov

    This is not mpd problem. This is problem inside netgraph.
    Only one way to resolve this problem - reboot server.

    Type "vmstat -z | grep NetGraph" and look in last column.
    If you found nonzero values, try to increase "net.graph.maxdata" and "net.graph.maxalloc" sysctl variables.

     
  • Aleksandr

    Aleksandr - 2013-03-22

    The output is:

    # vmstat -z | grep -E "(NetGraph|^ITEM)"
    ITEM                   SIZE  LIMIT     USED     FREE      REQ FAIL SLEEP
    NetGraph items:          72,   4118,       0,     377,  127712,   0,   0
    NetGraph data items:     72,    522,       0,     435,23721530,   0,   0
    

    There only two mpd interfaces ng0,ng1 and nothing else what use netgraph.

     
  • Aleksandr

    Aleksandr - 2013-03-22

    And restarting mpd (not reboot) helps for another 3-7 days.

     
  • Aleksandr

    Aleksandr - 2013-03-25

    Dear community, can anybody help me?

     
  • Dmitry S. Luhtionov

    This is netgraph problem. You must reboot server, to fix it.

     
  • Aleksandr

    Aleksandr - 2013-03-27

    Dear Dmitry, thank you.

    But this problem happens in random time. Sometime this server works 2-3 weeks with no problems, sometime this happens 2 times per week. But restarting only mpd helps. Users say that 2 routers with pppoe+pptp links works much stable :-(

    How can I make this server with mpd much stable?

     
  • Dmitriy Zamuraev

    What about to remove this lines from mpd.conf and use another nat mechanism?
    set nat red-port udp 0.0.0.0 20402 192.168.1.20 20402
    set nat red-port tcp 0.0.0.0 20402 192.168.1.20 20402
    set iface enable nat
    Just verify, other config lines looks like good for me

    What in this scripts?
    set iface up-script /usr/local/etc/mpd5/1_up.sh
    set iface down-script /usr/local/etc/mpd5/1_down.sh

     
    Last edit: Dmitriy Zamuraev 2013-03-28

Log in to post a comment.