ASCII STL is rendering incorrectly.

Users
2006-11-29
2012-10-10
  • Nobody/Anonymous

    I am trying to view an STL file which looks like:

    solid
    facet normal 0.0 0.0 0.0
    outer loop
    vertex -60.960000 -34.000000 0.000000
    vertex -60.960000 34.000000 0.000000
    vertex -54.864000 34.000000 0.078496
    end loop
    endfacet
    facet normal 0.0 0.0 0.0
    outer loop
    vertex -54.864000 34.000000 0.078496
    vertex -54.864000 -34.000000 0.201081
    vertex -60.960000 -34.000000 0.000000
    end loop
    endfacet
    facet normal 0.0 0.0 0.0
    outer loop
    vertex -60.960000 -45.000000 0.000000
    vertex -60.960000 -34.000000 0.000000
    vertex -54.864000 -34.000000 0.201081
    end loop
    endfacet

    ....

    facet normal 0.0 0.0 0.0
    outer loop
    vertex 60.960000 45.000000 0.000000
    vertex 60.960000 34.000000 0.000000
    vertex 54.864000 34.000000 0.066607
    end loop
    endfacet
    endsolid

    I know that the file has 120 facets, however Meshlab is rendering extra facets and is reporting that there are 180 facets.

     
    • Paolo Cignoni

      Paolo Cignoni - 2006-11-30

      It seem quite strange.
      Please, could you submit this issue as a bug report,
      in the sourceforge tracker page of the meshlab?

      http://sourceforge.net/tracker/?group_id=149444&atid=774731

      and attach to the bug report the zipped stl file?

      thanks in advance
      P.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks