#22 usbutils doesn't like libusb-1.0.0

open
nobody
None
5
2009-02-09
2009-02-09
Dennis
No

The configure fails with;

checking for uname... yes
checking for usb_get_string_simple in -lusb... no
configure: error: get libusb 0.1.8 or newer

Discussion

  • Philip Prindeville

    This has been open a while... I'm wondering if having usbutils not build against libusb-1.0 sends the message that other projects shouldn't bother trying to cut over to libusb-1.0 either...

     
  • Dennis

    Dennis - 2009-09-30

    If you install the libusb-compat libs, that should not be an issue.

    http://www.libusb.org/wiki/LibusbCompat0.1

    Not had any problems with libusb-1.0.3 and the compat libs here, but ymmv.

     
  • Philip Prindeville

    Except that in an embedded environment, you might be counting image size and the size of a shim library might not be justifiable.

    Also, usbutils is closely tied to libusb: what does it say that no one has bothered to update it to the new API? That the new API doesn't contain enough functionality to warrant the bother? We want to be aware what message that sends to people considering going with libusb-0.1...

     

Log in to post a comment.