Mounting a not cleanly unmounted disk

Help
2004-03-18
2013-04-23
  • Romuald Brunet
    Romuald Brunet
    2004-03-18

    I used hfsplus module to access files on my iPod from several weeks now.
    But I recently got into a problem I can't solve, I've disconected the iPod without unmounting it. The filesystem is OK when I check it on my Mac, but I can't mount it anymore read/write on Linux.
    The system tells me that it wasn't cleanly unmounted and needs a fsck.hfsplus (wich I haven't found) check.

    Does anyone knows a way to mount the filesystem readwrite or to mark the filesystem as "clean" for Linux ?

     
    • John Stolz
      John Stolz
      2004-03-19

      I had exactly this problem and it was kindly solved for me by Roman Zippel - her is the text of the message he sent to me:

      I ported the hfs tools by apple to Linux, the patch is at
      http://www.ardistech.com/hfsplus/diskdev_cmds.diff.gz and you need the diskdev_cmds archive from http://www.opensource.apple.com/darwinsource/10.2.5/ . You can apply the patch with "zcat diskdev_cmds.diff.gz | patch -p1" and then build the tools with "make -f Makefile.lnx", after you find a fsck_hfs in fsck_hfs.tproj.

      it worked fine for me.

      best of luck

       
    • Romuald Brunet
      Romuald Brunet
      2004-04-14

      Thanks for your help.

      To solve my problem I had to reformat the iPod on my Mac (then re-sync the music library and some files). It worked fine after that back on Linux.
      I'll try your solution next time if I happend to make the same mistake again o.O

       
    • Ben Greslick
      Ben Greslick
      2005-04-28

      This is a year late, but I've had this problem on a 2.6 kernel and a hfsplus Firewire disk. On the Mac OSX box I had to open disk utility, and do a verify/repair on the Firewire disk before Linux (2.6.10) would mount it rw again (and then make sure I unmounted it from the OSX box cleanly).  -Ben