Cosmetic changes
Added methods required for use with PDF
The original code was causing javac to throw an AssertionError. Working around the labeled break (by using a flag) seems to fix this fine.
Add one to number of Tnsot (number of tiles in tile-part header)
Verified all constants in AnWTFilterFloatLift9x7 against spec
setmask = (3<<bp)>>1 doesn't work in Java for bp 30 which results for 3 << 30 in a negative value and when rotating it one bit back Java will sign extend the number.
Some minor cleanups
Update some flags
Minor optimization
Update some enums
Add functionality to BitPacker to also append to bit position inside a byte offset
Make AttachmentPoints enum a little more friendly
Improve generation of Matrix from a Quaterion rotation
Delete packets directory before generating new packet classes
Update message map file
Improve a unit test a little
Fix some boolean operator errors
Add dirty flags support to TextureEntry
Add some extra Appearance values
Remove an unused include
Add GetBakeBytes() functions to TextureEntry and simplify the object variables and improve the code for the other getBytes() function
Add new capability to list
Update list of short text names for enum
Add extra parameter to ZDecompress function to indicate OSD format
Add extra functions to format ints and floats into an OutputStream
height and width were switched
Add new enums
Add some more information in the assert message
Make some modifications to the BitPacker and sub routines
a few changes to binary tools
Some optimizations in bitpack
Update OSGrid login link
Some collada import improvements
Add new message types
A few more minor quaternion improvements
Optimize Quaternion multiplication with Vector a little
Update some of the async libraries and start using them
Remove some unneccessary catch statements
Add HTTPDelete request method
create a common static function to retrieve the inventory capability
add set hover_height support
Replace some indexed loops with for each syntax
Add a very preliminary Collada Loader
Add a very preliminary Collada Loader
Imlement multilayer wearables and a few cleanups of unused types
Add check for 'NoGeometry' in TryDecodeFromAsset since some mesh faces are just place-holders. This resolves a crash for some OAR files.
Adapt to change in ManagedImage
Adapt to change in ManagedImage
Added support for active gestures
Begin AIS3 client impl
Second Life now reuses the "TaxFree" flag for AllowAccessOverride. Follow suit.
add deprecation comment
realign from previous edit
add comment
Add toString() to LightImage type
Fix a minor issue noted with folder short names resulting in incorrect inventory behavior with folder links.
Use cryptographically secure random generator to generate a GUID
Added an event for receiving server capabilities
The trigonometric functions in Java work all in radians, so correct the offset to radians instead of degrees
Adapt code to new changes in libomv core
Update image handling for different types
This is deprecated since JDK 1.2 and are only u...
Catch additional exception caused by last change
Some restructuring of managed image interface
Update some enumerations
Improve J2K encoding a little
Update copyright year
Minor cleanup to remove a public method in UUID
Some more cleanup in AssetItems
Add Pull parser source code to the archive
Open Archive Import Test runs without failure
Hide more of the internal implementation of ass...
Allow for BytesToStream to not bail out with Nu...
Remove unneccessary constructors
A first start for a test for the Open Archive i...
Create intermediate variable "InstantMessage im...
Improve some tests
A first start for an Open Archive asset importe...
Remove s from name for Primitive.SculptType.set...
More fixes to import from Xml
Fix some regular pattern matches
Remove RefObject parameter for TerrainHeightAtP...
fix substring endpos
Add cast for change to PushbackStream.getBytePo...
Add cast for change to PushbackStream.getBytePo...
Allow Xml UUID without inner <Guid> or <UUID> tag
Minor update
Improve XML parsing for type constructors
Fix a wrong constant
Add a getFileExtension() function with extra se...
Make the parsing a little more tolerant for str...
Make bytesRead a long
Remove deleteDirectory as it is in Apache Commo...
Add a directory delete function
Add xml export methods to some types
Fix binary stream constructor
Remove unused private method
Revert making isFormat() protected
Format example message so it's more readable
Make some methods protected