The incompatibility problem that required LdoWizard to be run with Ruby version 1.6.6 has been resolved. Any newer version of Ruby should work properly.
The LDO wizard requires Ruby 1.6.6. The documentation states that it needs 1.6.6 or higher, but it has been found that Ruby 1.6.7 and 1.7.2 both have an FXRuby problem that prevents the wizard from generating code successfully. The windows installer available from www.rubycentral.com for version 1.6.6 works correctly.