#33 Export from linked post is Forbidden

For Review
pending-postponed
Export (10)
6
2014-07-28
2011-11-09
No

The exact wording is:
Exporting Blog from a linked post generates Error: Forbidden!

We need this explained further with a reproducable example.

Discussion

  • Tim Parkinson

    Tim Parkinson - 2011-11-14
    • assigned_to: nobody --> cerysw
    • priority: 5 --> 6
     
  • Cerys Willoughby

    • assigned_to: cerysw --> theparkie
     
  • Tim Parkinson

    Tim Parkinson - 2012-02-17
    • milestone: --> v2.3 - Committed Development
     
  • Justin Bradley

    Justin Bradley - 2012-02-20
    • labels: --> Export
     
  • John Robinson

    John Robinson - 2012-07-05

    Linked blog is inaccessible, so can't investigate further.
    Is this still an issue?
    Can you / Colin widen access to allow logged in users to see srf_sandpit?

     
  • John Robinson

    John Robinson - 2012-10-08

    Can't seem to export any blog not owned by current user.
    Andy to investigate.

     
  • John Robinson

    John Robinson - 2012-10-08
    • assigned_to: theparkie --> ajm3
     
  • Andrew Milsted

    Andrew Milsted - 2012-10-08

    Look for other export bugs to check at the same time

     
  • Andrew Milsted

    Andrew Milsted - 2012-10-09

    Fixed svn:489 (will need to re run htaccess.php)

     
  • Andrew Milsted

    Andrew Milsted - 2012-10-09
    • status: open --> closed
     
  • Tim Parkinson

    Tim Parkinson - 2012-10-12
    • status: closed --> open
     
  • Tim Parkinson

    Tim Parkinson - 2012-10-12

    What is fixed here? Is it the original report or is it the "Can't seem to export any blog not owned by current user" comment? Or are they the same thing?

    If the are not the same thing then there should be a separate bug for the second one, not a comment.

     
  • John Robinson

    John Robinson - 2013-01-22

    Will revisit once export bugs have been fixed

     
  • John Robinson

    John Robinson - 2013-01-22
    • assigned_to: ajm3 --> j_robinson
     
  • John Robinson

    John Robinson - 2013-01-29

    Revisited prior to Labtrove 2.3 release, chased Colin to open his original comment so we can see what the issue is.

     
  • John Robinson

    John Robinson - 2013-01-29

    Colin's original blog entry says:

    16th November 2011 @ 14:26
    Action: Export_Blog
    The referenced says: "Exporting Blog from a linked post generates Error: Forbidden!"

    The following link goes to a post in "Smart Spaces eSI Theme", which is also on the same server. I have access to that blog and created the posts myself: Plan for the next workshop

    In Preview, when I click the link, I can view the post and see the options on the right-hand side. When I click Export Blog (expecting to dump the "Smart Spaces eSI Theme" blog), I get Error: Forbidden! - I get the same outcome after submitting this post.

    If nothing else, this is an unhelpful message.

     
  • Tim Parkinson

    Tim Parkinson - 2013-07-11
    • Group: v2.3 - Committed Development --> v2.4
     
  • Tim Parkinson

    Tim Parkinson - 2014-07-28
    • status: open --> pending-postponed
    • assigned_to: John Robinson --> David R Newman
    • Group: v2.4 --> For Review
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks