#592 Link menu item "Edit Link in New Window" often unavailable

0.8b2
open
nobody
5
2010-03-01
2010-03-01
G Erickson
No

In a simple web page that has a relative link to another page (in the same directory), right clicking on the link brings up the expected menu, but the "Edit Link in New Window" choice is often grayed-out and unavailable. I haven't been able to determine a repeatable sequence as to cause this -- it seems pretty random, but the choice seems to usually be available when I first open the page, but if I make some edits in the page (add some text having nothing to do with the link), it often then becomes unavailable in all links in all pages.

Seen in Windows XP Pro SP3 in 0.8b3 and 0.7.10.

Discussion

  • G Erickson

    G Erickson - 2010-03-01

    Simple test page A

     
  • G Erickson

    G Erickson - 2010-03-01

    Simple test file B

     
  • G Erickson

    G Erickson - 2010-03-01

    I attached some simple html files that show the problem for me.

     
  • G Erickson

    G Erickson - 2010-03-01

    I finally found a sequence of operations that will reliably show the problem:

    Download the attached Test-A.html & Test-B.html into some directory.
    Invoke KompoZer.
    Open Test-A.html.
    Right click on the link to Test-B and select "Edit Link in New Window".
    Click the Test-A tab.
    Click either hyperlink -- the "Edit Link in New Window" choice is still available.
    Click the Source tab then the Design tab below the Test-A window.
    Click any hyperlink in either document -- the "Edit Link in New Window" choice is no longer available. I've not found a way to get it back in the same KompoZer session.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks