Patch for compilation with gcc >= 3.4.0