Error at Jomic launch (AND LOTSA PROBLEMS HE

jonkoerner
2011-11-07
2013-04-24
  • jonkoerner

    jonkoerner - 2011-11-07

    When I start Jomic,  a command prompt window comes up with error message as follows.   Can someone please tell me what to do about this?

    log4j:WARN No appenders could be found for logger (net.sf.jomic.common.JomicStar
    tup).
    log4j:WARN Please initialize the log4j system properly.

    thanks
    JK

    P.S.   EVERY TIME I try to create a new message here, the first time through,  after writing my message, & clicking "Add Topic" button,   I get a delay for a while, then an error page --   and my message did not get stored.   I then go back through the entire process -- including LOGGING IN  to sourceforge  (it  seems to forget that I'm already logged in, when these errors occur),   rewrite my message, submit it again,    then it works okay the second time. 

    WHAT IS WITH THIS????  VERY ANNOYING!!!!

     
  • Thomas Aglassinger

    It's a warning, not an error. You can ignore it.

    Fixing it would require to clean up Jomic's logging. Over time, Jomic has had to use various logging libraries because different extensions libraries expected different logging libraries. By now this should have improved because pretty much any library is happy with Apache commons logging. However this still requires some major refactoring. It's not particular difficult, just plain boring.

    Concerning your login issues, I suggest you open SourceForge support ticket at https://sourceforge.net/support.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks