no java applets on Mozilla 1.7.13 / OS 10.1.5

Help
2006-05-03
2013-04-16
  • Christophe Roguet

    hi,
    I'm trying to get java applets to run in the above mentionned environment and after reading mozilla's release notes and the JEP readme file, and as my system  only has java 1.3.1 I thought I could try just using the MRJ Plugin bundled with JEP 0.9.5 (i.e. not using the JEP plugin)
    what happens is that Mozilla's correctly lists the MRJ plugin and says java is enabled, and yet when I try to open a page containing an applet I get a "get the plugin" jigsaw puzzle message - but the link finds no plugin
    I do have java 1.3.1 installed on my system : it is correctly used by internet explorer, for instance

    is my configuration supposed to work ? are there additional or different plugins that I should get ?

    for any help you can provide, thanks in advance

     
    • Steven Michaud

      Steven Michaud - 2006-05-03

      The problem is that the latest version of the MRJ Plugin JEP (0.9.5+d)
      is only available as a "universal binary" (one that can be used on
      both Intel Macs and PPC Macs).  But the Mozilla Suite can't load a
      plugin that's a universal binary.  Try using MRJPlugin.plugin from the
      last version of the Java Embedding Plugin that was PPC-only (JEP
      0.9.5+c).

      (By the way, I just stumbled upon this problem myself.  In my next JEP
      release, I'll include both universal binaries and PPC-only binaries.)

       
      • Christophe Roguet

        no it's not the same problem : I had downloaded JEP 0.9.5 which was PPC only
        I've also tried JEP 0.9.5+c
        in either case, the plugin is correctly listed by Mozilla as enabled, yet I can get no applet to run !

         
    • Steven Michaud

      Steven Michaud - 2006-05-04

      Well, then it may be that the MRJ Plugin JEP doesn't work on OS X
      10.1.5.

      I've never tested either part of the JEP on OS X versions earlier than
      10.2.8 (and probably never will).  And the Readme does say that 10.2.8
      or above is required.

       
      • Christophe Roguet

        ok

        does this mean that I should give up all hope of getting java applets to run with mozilla or firefox on my system, or are there alternatives that I could try ?

         
    • Christophe Roguet

      I've now installed FireFox 1.0
      the behaviour is slightly different :
      when the MRJ plugin is not installed the browser displays the "get the plugin" message
      when the MRJ plugin is installed the browser doesn't display anything (i.e. the window is white, empty) ; again, the plugin is listed as enabled in the "plugins" page

       
    • Steven Michaud

      Steven Michaud - 2006-05-05

      I don't know.  It's been many years since I last used OX X 10.1.

      You might try (re)installing Apple's "Java 1.3.1 Update 1":

      http://docs.info.apple.com/article.html?artnum=122000

      You could also try the version of the original MRJ Plugin that's
      bundled with Camino 0.8.5:

      ftp://ftp.mozilla.org/pub/mozilla.org/camino/releases/MRJPlugin.gz

       
      • Christophe Roguet

        using this MRJPlugin solved the problem for both Mozilla and Firefox !

        thank you very much, I was almost starting considering upgrading my system !

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks